cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

SetConfigurationTable not working

SOLVED
Highlighted
Newbie

SetConfigurationTable not working

Using Thingworx 7.1.2:

We have noticed that if we call (via Thingworx REST calls) SetConfigurationTable and pass in some JSON with more than one property then calling GetConfigurationTable (again via REST) will return us the new values we set. However, looking at the configuration in the Thingworx composer shows us that these values have not been set. Restarting Tomcat confirms that the values are lost.

We have also tried calling SaveConfigurationTables() after making these changes but that has no impact.

Setting a single value in the SetConfigurationTable call works correctly and the changed value is persisted between tomcat restarts too (we left the SaveConfigurationTables() call in there, don't know if this was necessary but I assume it is otherwise what is this function there for?)

So, my question is are we doing something wrong? Is there a step missing?

Thanks - Brad

Tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: SetConfigurationTable not working

Setting the persistent flag to TRUE has made it work. Weird that this wasn't needed if only setting one property though.

Anyway, problem solved. Kinda.

View solution in original post

1 REPLY 1
Highlighted

Re: SetConfigurationTable not working

Setting the persistent flag to TRUE has made it work. Weird that this wasn't needed if only setting one property though.

Anyway, problem solved. Kinda.

View solution in original post

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum!