cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Thingworx Mashup Editor loading infinitely

TanmeyTWX
16-Pearl

Thingworx Mashup Editor loading infinitely

Hi Folks,

 

Suddenly all the Mashups editor started loading infinitely. When I click EDIT and select DESIGN view, it goes into an endless loading although its working fine in runtime. I have the same set of mashups on another test server and seeing no such issue there.

I tried to observe for errors in Developer mode and found below.

 

1. 404 error for the mashup.

TanmeyTWX_0-1648627769431.png

 

Response

<!DOCTYPE html>
<html>
<head>
<title>Page Not Found Exception</title>
<script>function clickAndDisable(link) {
link.onclick = function(event) {
event.preventDefault();
}
}
</script>
</head>
<body>
<div class="widget-panel widget-container widget-content" style="overflow: auto;">
<div class="widget-content widget-image undefined"
id="error_Image-1">
<img src="/Thingworx/images/ThingworxLogo.png" alt="Errors"/>
</div>
</div>
<div id="error_Panel-1"> <p>404 Page Not Found</p>
<a href="/Thingworx" onclick='clickAndDisable(this);'>Back to Composer</a> </div>
</body>
</html>

 

I have also validated the external extensions and if any extra folder created under tomcat Webapps but everything looks fine.

 

Please let me know if anyone came across similar issue in Thingworx?

1 ACCEPTED SOLUTION

Accepted Solutions
slangley
23-Emerald II
(To:TanmeyTWX)

Hi @TanmeyTWX

 

Per the case, it was found that some files were missing, including index.html and css extension files, and that the server was misconfigured.

 

If you agree that this was the solution, please mark this response as the Accepted Solution for the benefit of others with the same issue.

 

Regards.

 

--Sharon

View solution in original post

7 REPLIES 7
PaiChung
22-Sapphire I
(To:TanmeyTWX)

I recommend you contact technical support

Hi Pai,

 

I can see below errors in application logs. Please let me know if you have any idea about this and somehow it is related to this Mashup editor issue.

  • 2022-04-01 07:13:03.537+0000 [L: ERROR] [O: c.t.c.p.m.DispatchingServerCommunicationModule] [I: ] [U: ???] [S: ] [P: ] [T: http-nio-8081-exec-2] Missing application key!
  • 2022-04-01 07:13:03.537+0000 [L: ERROR] [O: c.t.c.s.c.j.Jsr356ServerConnection] [I: ] [U: ???] [S: ] [P: ] [T: http-nio-8081-exec-2] Error [authenticating connection], Server websocket will be closed. cause: Missing application key!

 

 

Hi @VladimirN @slangley 

 

Case 16327773 has been opened for this issue. Could you please help me to expedite the process?

 

 

VladimirN
23-Emerald IV
(To:TanmeyTWX)

What priority level have you set for your Case?

slangley
23-Emerald II
(To:TanmeyTWX)

Hi @TanmeyTWX.

 

I checked on your case and can see that it's still being worked.  However, this issue can happen as the result of installing an incompatible extension.  Have you installed any custom extensions, older extensions or third party extensions that might explain the issue?  You can try removing it to see if it resolves the issue but I recommend making sure you have a backup/snapshot of your app server and a database backup before making any changes.

 

Regards.

 

--Sharon

Hi Sharon,

 

Yes, case has been assigned to PTC support guy and I am in discussions with him. I do have multiple custom extensions and have same set of extensions installed on another TWX instance which is working fine. So I guess extensions shouldn't be the cause of this issue. But thanks for suggesting this observation as well.

slangley
23-Emerald II
(To:TanmeyTWX)

Hi @TanmeyTWX

 

Per the case, it was found that some files were missing, including index.html and css extension files, and that the server was misconfigured.

 

If you agree that this was the solution, please mark this response as the Accepted Solution for the benefit of others with the same issue.

 

Regards.

 

--Sharon

Announcements