cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Thingworxwox Foundation installation

SOLVED
MSJ
5-Regular Member
5-Regular Member

Thingworxwox Foundation installation

I want to install thingworx foundation on my pc but finding it difficult. Could someone recommend a video tuttorial or some that will guide me through successfully? 

Thanks. 

1 ACCEPTED SOLUTION

Accepted Solutions
lchan1
4-Participant
(To:MSJ)

You should use

 

sudo addgroup --system tomcat8.5 --quiet --force-badname

--force-badname instead of 

—force-badname

 

View solution in original post

16 REPLIES 16
zyuan1
18-Opal
(To:MSJ)

Hi, I don't think TWX have installation videos, and Community is a "Low Touch" support method, if you need someone to closely follow your installation process, It's highly recommended that you create a case for it.

MSJ
5-Regular Member
5-Regular Member
(To:zyuan1)

Hi,

Thank you for the concern. It is so frusting on windows.

I have decided to use Ubuntu and still going well but while running this command "

sudo addgroup --system tomcat8.5 --quiet —force-badname

"

to add group to the folder tomcat8.5, it keep saying not does not exist. how do I rectify this?

 

I am not sure I understand what you meant by creating a case.

zyuan1
18-Opal
(To:MSJ)

Did you successfully extracted the tar file?  Was the file in the correct path?  These are generally 2 steps before this addgroup command,  You just started installation so the reason must be quite simple.

 

By "Creating Case" I mean if you're a TWX client (higher than Silver) or PTC insider, you could use your account to create a technical support case in the esupport website, and a TWX engineer will pick it and help through the problem you have.

MSJ
5-Regular Member
5-Regular Member
(To:zyuan1)

Thank you for your concerned.

Yes I extracted the tar file and even to it the recommended folder. 

I could locate that in the folder.

 

So I don't really know what is wrong.

lchan1
4-Participant
(To:MSJ)

You should use

 

sudo addgroup --system tomcat8.5 --quiet --force-badname

--force-badname instead of 

—force-badname

 

View solution in original post

MSJ
5-Regular Member
5-Regular Member
(To:lchan1)

Thank you you so much for spotting the problem. Now solved but next command just that one is giving me this challenge, I will appreciate if you can still help though your solution is accept as the answer to the problem.

 

Command:

$ sudo adduser --system --home /usr/share/tomcat8.5/ --no-create-home --ingroup tomcat8.5 --disabled-password --shell –force-badname/bin/false tomcat8.5

 result when run:

 

mbolij@mbolij-VirtualBox:~$ sudo adduser --system --home /usr/share/tomcat8.5/ --no-create-home --ingroup tomcat8.5 --disabled-password --shell --force-badname/bin/false tomcat8.5
[sudo] password for mbolij:
Sorry, try again.
[sudo] password for mbolij:
adduser: Please enter a username matching the regular expression configured
via the NAME_REGEX[_SYSTEM] configuration variable.  Use the `--force-badname'
option to relax this check or reconfigure NAME_REGEX.
mbolij@mbolij-VirtualBox:~$

 

Any solution please?

raluca_edu
17-Peridot
(To:MSJ)

Hi,

 

Try to use:

 

sudo useradd -r -d /usr/share/tomcat8.5 -g tomcat8.5 -s /bin/false tomcat8.5

 

Regards,

Raluca Edu

MSJ
5-Regular Member
5-Regular Member
(To:raluca_edu)

Thank you reluca_edu,

 

I ran that and it added successfully. I don't really if I am following a tutorial or what.

 

The next line of comand produces this as again and I can't either the missing operand.

 

 

mbolij@mbolij-VirtualBox:~$ sudo chown -R tomcat8.5:tomcat8.5/usr/share/tomcat8.5;
chown: missing operand after ‘tomcat8.5:tomcat8.5/usr/share/tomcat8.5’
Try 'chown --help' for more information.
mbolij@mbolij-VirtualBox:~$

 

Any help is highly appreciated.

 

Thanks.

raluca_edu
17-Peridot
(To:MSJ)

Missing a space in command, please use:

 

sudo chown -R tomcat8.5:tomcat8.5 /usr/share/tomcat8.5

 

Thanks,

Raluca Edu

MSJ
5-Regular Member
5-Regular Member
(To:raluca_edu)

Thank you for allowing me to tap from your well of experience.

Don't be tired of me as I may contact you again in future challenges.

 

It worked.

MSJ
5-Regular Member
5-Regular Member
(To:raluca_edu)

Hi,

It's been going on well but I have encountered this.

 

  • Uncomment the Manager element in $CATALINA_HOME/conf/context.xml to prevent sessions from persisting across restarts:

    <Manager pathname="" />
    When ran, it shows this.

mbolij@mbolij-VirtualBox:/usr/share/tomcat8.5/8.5.31$ <Manager pathname="" />
bash: syntax error near unexpected token `newline'
mbolij@mbolij-VirtualBox:/usr/share/tomcat8.5/8.5.31$

 

Don't know how to fix this.

 

raluca_edu
17-Peridot
(To:MSJ)

Please upload the context.xml file to check it. Seems to be a syntax error.

MSJ
5-Regular Member
5-Regular Member
(To:raluca_edu)

I don't about the file, where can I locate it?

raluca_edu
17-Peridot
(To:MSJ)

Please go in location where you installed Tomcat, you will find conf folder and inside there is context.xml.

Open file in edit mode and delete the characters in front and after  of <Manager pathname="" />.

 

Best regards,

Raluca Edu

MSJ
5-Regular Member
5-Regular Member
(To:raluca_edu)

Hi Raluca,

 

Thank you so mcuh.

 

I located the conf folder but says I have no permission to open it.

 

See attachments.

 

Thank you.

 

Julius

raluca_edu
17-Peridot
(To:MSJ)

Hi Julius,

 

Open file from terminal using sudo and a text editor:

 

e.g: sudo gedit context.xml

 

Thank you,

Raluca

Announcements