cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade TWX, Postgresql scripts 8.1 to 8.2

SOLVED
Regular Member

Upgrade TWX, Postgresql scripts 8.1 to 8.2

Hello,

 

I recently perform an update from TWX 8.1.0 to 8.2.5 and I noticed that there is the requirement to run the scripts in the update folder, but I do not understand why this step is necessary because when I checked the script it does not do anything.

I want to omit this step and from what I saw it can be, but I do not understand why it exists in the documentation?

 

Best regards,

Marius

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Upgrade TWX, Postgresql scripts 8.1 to 8.2

Hi Marius,

 

When ThingWorx upgrades between big versions (like 7.3 to 7.4, 8.0 to 8.1), there are usually some structure changes inside the datastorage unit, and sometimes you may find out that the number of ThingWorx related tables are changing between different versions, and that's why we need to run the upgrade bat files to make the persistence provider match with the newer TWX server.

 

Surely there might be no changes between some versions, and the bat files are doing nothing, but when some longtime users  decided to upgrade from 7.4 to 8.3, we can't leave a gap in between all the upgrade files, so a blank file will be created to make it easier to understand (which will not cause much extra work)

4 REPLIES 4

Re: Upgrade TWX, Postgresql scripts 8.1 to 8.2

Hello, Marius.

 

Please see the PM I sent you about this question.

 

Thanks,

 

-- Craig A.

Re: Upgrade TWX, Postgresql scripts 8.1 to 8.2

Hi Marius,

 

When ThingWorx upgrades between big versions (like 7.3 to 7.4, 8.0 to 8.1), there are usually some structure changes inside the datastorage unit, and sometimes you may find out that the number of ThingWorx related tables are changing between different versions, and that's why we need to run the upgrade bat files to make the persistence provider match with the newer TWX server.

 

Surely there might be no changes between some versions, and the bat files are doing nothing, but when some longtime users  decided to upgrade from 7.4 to 8.3, we can't leave a gap in between all the upgrade files, so a blank file will be created to make it easier to understand (which will not cause much extra work)

Re: Upgrade TWX, Postgresql scripts 8.1 to 8.2

Thank you @zyuan1!

Re: Upgrade TWX, Postgresql scripts 8.1 to 8.2

Hi Marius,

 

If that help, please mark my answer as correct so that we can close this thread.