cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Visual SDK - Getting Started Tutorial

AlessandroN
11-Garnet

Visual SDK - Getting Started Tutorial

Hi, I'm new to Polymer and I'm trying to create my first widget using the Visual SDK.
When I try to launch polymer from the simple-el folder, it doesn't give me the correct output on the browser (Chrome) (attached page1.PNG).
Opening the inspector, the console shows this error: 

 

Uncaught DOMException: Failed to execute 'define' on 'CustomElementRegistry': the name "dom-module" has already been used with this registry
    at http://127.0.0.1:8081/components/@polymer/polymer/lib/elements/dom-module.js:176:16

 

 

I think it is a problem due to a library conflict on npm (d3-array), but I'm not sure about it.
There's anyone who has already faced this issue? 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi, I solved in the most simple way ever...following the guide.
The command:

> polymer serve --open

 Automatically redirects on a bad path that is different from the one explained in the guide.

The correct one was:

http://127.0.0.1:<port_number>/demo/

View solution in original post

2 REPLIES 2
slangley
23-Emerald I
(To:AlessandroN)

Hi @AlessandroN.

 

Can you clarify that you're referring to the Web Component SDK?  What version of ThingWorx are you running?

 

There was a conflict with the d3 JS in ThingWorx 9.0 but it was corrected in 9.0.2 and 9.1.

 

Regards.

 

--Sharon

Hi, I solved in the most simple way ever...following the guide.
The command:

> polymer serve --open

 Automatically redirects on a bad path that is different from the one explained in the guide.

The correct one was:

http://127.0.0.1:<port_number>/demo/

View solution in original post

Announcements