cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Want to include all columns in ThingWorx Analytics Model

SOLVED
Highlighted
Regular Member

Want to include all columns in ThingWorx Analytics Model

Hi,

 

I want to include all the columns except not the Goal in the Model. I am forced to create a Filter. Is there a way to include all columns.

 

Thanks and Regards,

Jyothi

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Want to include all columns in ThingWorx Analytics Model

Jyothi,

 

What version of Analytics Server are you using?

 

It sounds like you encountered a known issue, where the Configuration Service was not run after installation of the Extensions.

 

Can you please take a look at this article: https://www.ptc.com/en/support/article?n=CS279917

 

And let me know if that resolves your issue?

 

Regards,

 

Neel

3 REPLIES 3

Re: Want to include all columns in ThingWorx Analytics Model

Jyothi,

 

Thank you for your post to the Community.

 

There should be a default filter, called "all_data" available to you for modeling jobs.

 

Regarding excluding the goal, you cannot exclude the goal from a modelling job, as it is required for the creation of the model.

 

Please let me know if this answers your question.

 

Regards,

 

Neel

Re: Want to include all columns in ThingWorx Analytics Model

Thanks Neel. But I am not able to see the all_data filter. When I click on Copy Definition from Existing Filter in the Create Filter dialog, I get an error.

 

Errors in Script Logs is

GetFiltersRowCountByDatasetAMS: Error: JavaException: com.thingworx.dsl.exceptions.DSLRequestProcessingException: Execution error in service script [GetFiltersRowCountByDatasetAMS] :: TypeError: Cannot call method "GetFilters" of null (GetFiltersAMS#14)

[message: Execution error in service script [GetFiltersAMS] :: TypeError: Cannot call method "GetFilters" of null (GetFiltersAMS#14)]

Re: Want to include all columns in ThingWorx Analytics Model

Jyothi,

 

What version of Analytics Server are you using?

 

It sounds like you encountered a known issue, where the Configuration Service was not run after installation of the Extensions.

 

Can you please take a look at this article: https://www.ptc.com/en/support/article?n=CS279917

 

And let me know if that resolves your issue?

 

Regards,

 

Neel