Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

The PTC Community email address has changed to Learn more.

Thingworx Studio Animation not working


Thingworx Studio Animation not working

Hi All,


               i am working in thingworx studio and facing problem with the animation of a (.pvz) file also have given the (.pvi)  that is sequence file and using a button handled on click event to play the sequence(Animation)  but still there is nothing happening.

Following is the error i got in Log

[0mGET /css/ionic-combined.css  [36m304  [0m2.226 ms - - [0m

[0mGET /favicon.ico  [36m304  [0m0.708 ms - - [0m

              attaching the file (.pvz) please help me in the same.

Thanks & Regards

Pravin Pradhan

Message was edited by: pravin pradhan


pravin pradhan​ : It seems the attachment is missing so request you to please share the .pvz file to assist you with the issue ?


yes here you go Durgesh Patel​​ sorry but dont know how i missed that, here is the attachement ! ! ! ! !

help me to understand that where im going wrong and if possible please provide one .PVZ you have. Thanks

5-Regular Member

Hi pravin pradhan​,

Please try downloading the Blue pump Exercise from the ThingWorx Studio – Unleash your imagination.

to see if it works.

Thanks for replay Ankit Gupta​ yes i tried the same and its working properly but facing problem in all other PVZ files, thats why i m unable to understand where i made mistake. Can you please go with the attached file of compressor ? and let me know that what you get. please

I am having the same problem. It is likely because we are using an animation not a sequence.

This is a problem as you cannot import mechanism data into a sequence, amongst other reasons.

This is my process after creating the animation in Creo Illustrate.

I've never seen an animation ​play in ThingWorx studio, only sequences. Is it possible to play animations and if so how?

pravin pradhan​ and Tom Parker​ Are you using Creo Illustrate to build the model (and its animation)? Or do you use other applications like Creo Parametric etc.,

Also the problem is only with animation or sequence (not played), is it correct? And you are able to see the Model being loaded right?

Yes You are right  @giri i am using creo illustrate to build model and animation and the problem is with sequence and i can see the model perfectly.

This is my entire process to build the experience from Creo Parametric > Creo Illustrate > ThingWorx Studio.

You can see when I preview the animation it does stutter at the start as if it is going to play. It's worth noting it is not just the preview that doesn't play, the published experience view on phone/tablet doesn't play.

Looking into your video, it looks like Studio is able to play one sequence step. That might be because you are binding the button click event with "PLAY" service, instead can you please try binding with "PLAY ALL" service of the 3D-model widget?

Also, is it feasible for you to share the PVZ file for troubleshooting the issue? so that I can see there is a problem with model components (in Creo illustrate). If so, please feel free to send a private message to me.


I did try the 'Play All' option with no success either.

Attached is the PVZ I have been using, created in the same way I referenced above in the video.

I suspect the 'step' when I try and play the mechanism in ThingWorx Studio is because it is playing the entire animation instantaneously.

Thanks for taking a look!

In this case we have two different functionality. Ok in both cases there is a PVI file inside  the pvz file when we publish from Illustrate to PVZ file but there is an essential difference.

> in the one case we have created the figure by  creating of different steps - using the Creo Illustrate effects and translations +rotations and giving a time interval for each step - so we define of the time duration of the step

> in the other case we create an animation using an .fra file coming from   mechanism design

20-05-2017 19-45-07.jpg

The fra file contains a frames of matrixes for the  different components. The whole animation  defines  a particular number of frames so that between every frames is a exact the same time persiod. When we look in the piv file created for the animation -there  seem that this matrix data is overlooked in the pvi file for the animation figure.

> the sequences effects seem to use step location which is some kind of euler transformation.

So fact is that behind the both pvi file is a different syntax and I believe that  animation is not supported because I already heard statement that fra file is not supported but this animation is a kind of fra file import.

May be will be a good idea if this could be checked by PTC development.

Video Link : 1887 A

Hi Roland Raytchev​  please help me to understand, i created a PVZ and PVI file which i have already attached but as you said it should be sequence and not .fra as i know its not .fra and has a time interval for each step still its not working on Thingworx studio can you help me to understand what i am missing in the same.

Note = I can see the 3D product on Screen (PVZ) but when i mapped it to button(OnClick) -> play (or play all both tried) still on preview there is no effects (just can see first step)

Ankit GuptaThingWorx Studio

Hi Pravin,

yes, it was not  may be not quite correct where I asumed that you have used an animiaton created with a fra file. I did not consider that you can also create an animation in Creo Illustrate  without to use   a *.fra file!

So let consider what is possible.

-> creo Illustrate we  can create some animated sequence in 2 way.

- the first way what will create a *.pvi file and this pvi file is working also in studio -> is to create   first a figure and then to go the sequence tab and create some steps



- the other way what seems currently to create a *.pvi which is not working in Studio --> is to use anmation

There are two option to create an animation in Creo Illustrate. The one I mention was to use a *.fra file which you can import

and ase developer states this is not supported yet!

- here I forgot in my last replay the option to create the whole animation inside the Creo Illustrate Interface. So this mean that *.pvi of animation which is created in the animation tab will also not work in Studio - so my founding when I tested it.

I tested such animation in Creo Illustrate 4.0 and my experience was that when we specify the *.pvi (coming form the animation) in the Sequnece URL

in this case it display the finish animation status - so as the model played the animation

When I tested you model - it show the unchanged the model -but my be this is caused by the usage of different Creo Illustrate version (I used now the 4.0 could not found the 4.1 for download)

But so far I understand the Developer statement it should work because it is fully  created inside the Creo Illustrate interface. So I think this should be reported.

One additional think what we can do is to check what is so different in the both pvi files... I am considering to create a very simple animation and sequence performing the same thing an to check what is the difference in the syntax. May be adding some additional fake tag could help...

Thanks Roland Raytchev​ , make me correct if im wrong, you mean to say that if i try the same model with creo 4.0 it should work right?

We asked the PTC development and received the following answer:


->only supported pvi at the moment are those authored using Creo Illustrate;

->other animations will be recognized (because of the file extension) but not played, as you have seen in the report.

->PTC does have plans to support this in the next future but there is no fixed date yet.

I saw a presentation late last year that showed plans for Creo Illustrate 4.1 to support the import of FRA files from Creo Parametric into Creo Illustrate sequences.  At the moment, they can only be imported into animations, which are not supported by ThingWorx Studio.  So as long as this functionality makes it into 4.1 (fingers crossed) it could provide a fix for people who want to show an animation created in Creo Parametric in an experience.

But it would be nice to see Creo Illustrate Animations supported in Studio.

Unfortunately, it seems that the ability to import a FRA file of an animation from Creo Parametric into a sequence isn't going to happen with Illustrate 4.1.

Hi Allan,

today I was in meeting where in a presentation was shortly  mentioned that end of June or  Middle of July a new version should be released which will be able to handle animations

So what I am not sure - where this functionality will be implemented: on the Thingworx Studio side or on the Creo Illustrate side. There was also a discussion about some interactions created in Illustrate what I do find in my Creo Illustrate version (4.0) – so this points more than for Illustrate but  still what I believe is that this will be on the ThingWorx side. Because we have already a *.pvi created in the Creo Animation (by Creo Issusltarte UI or imported by *.fra file)  so that we need only an engine which could play it … but as mention we need to wait and see…



Hi Roland,

I'm guessing that the ability to handle the animations will be on the ThingWorx Studio side.  I want to do the same thing you are trying - use an animation of an engine done in Creo Parametric in an AR experience.  So I can export out the FRA file from Parametric and import it into an animation in Illustrate.  But the problem is that when I export out from Illustrate, Studio cannot use the PVI file for an animation.  Last year,there was talk that Illustrate 4.1 would allow you to import a FRA file into a sequence, but it's been confirmed that that bit of functionality did not make it in.   It might be in there in the next release at the end of this year, so until then, the only solution will be if Studio can use a PVI file created from an animation in Illustrate.  I really hope that's the case.