cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

don´t show symbol in my animation

SOLVED
Garnet

don´t show symbol in my animation

Why do not the symbols appear in the animation in my application? , you do not see the screwdrivers or the 
arrows
 
(view in My Videos)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: don´t show symbol in my animation

Symbols don't transfer from Creo Illustrate to Thingworx Studio. There is a workaround, which is to add the actual symbol models to your BOM in Creo Illustrate. To do this, find your Creo Illustrate symbols library (usually in {user-directory}\AppData\Roaming\PTC\Illustrate\SymbolsLibrary\Shape), and import the *.ol model for the symbol you want into your illustration. Use this instead of the Symbols feature in Creo Illustrate, and it will carry over when you bring it into Thingworx Studio.

 

--Clay

View solution in original post

11 REPLIES 11

Re: don´t show symbol in my animation

Symbols don't transfer from Creo Illustrate to Thingworx Studio. There is a workaround, which is to add the actual symbol models to your BOM in Creo Illustrate. To do this, find your Creo Illustrate symbols library (usually in {user-directory}\AppData\Roaming\PTC\Illustrate\SymbolsLibrary\Shape), and import the *.ol model for the symbol you want into your illustration. Use this instead of the Symbols feature in Creo Illustrate, and it will carry over when you bring it into Thingworx Studio.

 

--Clay

View solution in original post

Re: don´t show symbol in my animation

hi, do you have a example or video or screenshot? 

Re: don´t show symbol in my animation

Here are a couple of screenshots, showing loading the symbol model from the symbol library, and then showing the loaded model in the studio canvas.

Re: don´t show symbol in my animation

And here are a couple of screenshots showing how to do the same thing in Creo Illustrate. When you load a symbol this way, as if it were just another CAD model, it appears in the sBOM as usual.

Highlighted

Re: don´t show symbol in my animation

Any luck using multiple of the same part (Symbol)? I.E. I want multiple arrows, do I really have to make copies of the arrow in order to import multiple arrows? Otherwise how can I Add mutiple arrows to the animation? This is laughably hard to use vuforia with other ptc software, nothing is intuitive, IMO ^_^.

Re: don´t show symbol in my animation

Not that I'm aware of. Creo Illustrate seems to assume that everything you need will be included in your base CAD assembly.

 

In cases where I've needed to add multiple instances of an additional component, for example multiple mounting screws, I have done so by creating a CAD assembly consisting of the number of screws I need, and then bringing the assembly into Creo Illustrate. There I can position and animate each screw as needed along with the main assembly components.

 

I agree, this is definitely an opportunity for PTC to improve the usability of Creo Illustrate. It would be great if they would add support for 3D symbols, and for importing multiple copies of the same CAD object (or duplicating an object in the BOM once it's imported).

Re: don´t show symbol in my animation

(To be clear, what I mean by "support for 3D symbols" is "3D symbols in figures should be included as 3D objects in PVZ publish for import into Vuforia Studio". If that means a separate 3D publish type specific to Vuforia Studio, that would be fine.)

Re: don´t show symbol in my animation

Hi @ClayHelberg,

So far I understand  a statement of PTC Devat least 3d symbols should be supported in Studio

 

To verify now I tested only in preview mode (I supposed that when preview mode is not working no sense to check on end device) and observed that sequences does not show the symbols added by the Creo Illustrate menu Home(Tab) > Symbols

 

I tested with Vuforia Studio 8.4.2 and Creo Illustrate 5.1

-sequence with 2d and 3d symbols - > in studio preview no symbols are displayed

-sequence only with 3d symbols - > in studio preview no symbols are displayed

 

All other Items in the keyframe editor are played as expected but no display for the symbol’s items

so seems still not to work! Unfortunately!

 

Current Workaround : 

is to add the symbols (as .0l) to the assembly and using the different effects.

Also, 2d symbols should be implemented as 3d object

=====================

Requested info by  PTC  R&D - when I receive an answer will provide here a feedback

Re: don´t show symbol in my animation

Thanks for the update on that. I wonder if there is some new option or setting in Creo Illustrate to force the symbol objects to be exported with the PVZ file when published, but which is off by default?