Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Learn all about PTC Community Badges. Engage with PTC and see how many you can earn! X

thingworx studio stop working


thingworx studio stop working

I have been using ThingWorx Studio for around a week, it stopped working for what every reason. so i am trying to reinstall it. I seem to been having a problem reinstalling it.

Application cannot be started contact the application vendor. attached is the log file can any one help i was doing so well!

Message was edited by: Sushant Pandey moved to ThingWorx Studio Community


What happens if you download the URL in the log (via the browser) and install it via this file?

You can also check out this article... it mentions some of the directories where (temp) files might be stored - maybe they are interfering with the new installation, so be sure to clean those directories out after de-installing Studio.

Hi Michael, I have tried using the link I seem to get the same problem as before.

5-Regular Member

Hi FITZ BENJAMIN​, Could you please share the steps followed to reinstall ThingWorx Studio.

From the logs it seems that some file cannot be found and the activation failed.

I would recommend you to restart the Server after the uninstall.


Ankit Gupta


Hi Gupta;

I have followed the details for uninstalling ThingWorx information


emoved the ThingWorx folder from within document

  1. I also within user Users\myname\AppData\Roaming
  2. Restarted
  3. Tried to install again and I get the same problem
  4. I have also tried the URL Link


I have attached the install log file

Any ideas?


Microsoft .NET Framework 4.5.2 is installed correctly?

(as it says "no install needed" I'd guess it is, but a confirmation on this will be helpful)


The current status of my problem.

  1. After trying all the posted recommended work a round’s which need not same to resolve the problem
  2. I made a discsion to rebuild mypersonal computer from the OS upwards and reinstall my application, it was running a bit slow anyways
  3. I then reinstalled ThingWorx Studio, it worked first time round without any problems.

Device Type :

  1. Windows 7 pro
  2. Service pack 1




Has anyone solved this problem? I am getting similar problem. Studio working fine on Windows 10 and then it stopped working. That is the application launches correctly but then when I click to open (localhost), i get spining thingmark logo and waits forever.

I tried uninstall and reinstall Studio and same problem.

Any help appreciated.

Go to %userprofile%\AppData\Local\Apps and delete the 2.0 file. Reinstall the setup file and you will have access again.

Good luck,


Top Tags