cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Recent Chrome Update Possibly Affects Windchill

BrianToussaint
19-Tanzanite

Recent Chrome Update Possibly Affects Windchill

This is more of a post letting others know what I encountered today with my Chrome-Windchill connection, but if anyone knows what is going on that would be great to know.  It seems that Chrome recently updated their browser, mine is showing 83.0.4103.97, and I am now having issues with it.  I have cleared all the history out of Chrome and it still has the issue.  The issue has been seen across multiple computers, is that during the creation of a CN, when you go in and edit the task during that creation a blank window pops up with the spinning circle of death.  I am on Windchill 11.2.1.0.  The only error that is in any of the logs is:

2020-06-05 07:51:47,667 ERROR [ajp-nio-127.0.0.1-8015-exec-1] com.ptc.windchill.enterprise.change2.tags.ChangePropagationTag <USERNAME> - action oid was null

 

I have opened a support call and am waiting to hear back from them.

 

I don't know if anyone else has seen this yet or not.

123 REPLIES 123
KimH
11-Garnet
(To:RK10)

Windchill 11.0 M030 CPS14 running HTTPS

Issue occour with:
Chrome 83.0.4103.106
Edge 83.0.478.50

So, I cannot confirm that the issue only exist for HTTP... At least not for our specific Windchill version.

aacciano3
13-Aquamarine
(To:KimH)

@KimH 

 

Are you saying that Edge with Chromium engine is affected as well?

KimH
11-Garnet
(To:aacciano3)

@aacciano3, Yes, that is correct. Edge (Chromium) version 83 is affected as well. I guess, we can assume that all Chromium based browsers are affected.

scaporaletti
4-Participant
(To:KimH)

Hi,

I tried today with the latest realese of Chrome 83.0.4103.116 on Windchill 11.1 M010 and the issue doesn't occour.

 

Hello,

In my case Chrome 83.0.4103.116 

on Windchill 11.0 M030  CPS15 the issue is reproducible.

on Windchill 11.1 M020  CPS08 the issue is reproducible.

on Windchill 11.1 M020  CPS13 the issue is reproducible.

all versions are on HTTP.

Best Regards.

 

PetrH

 

bmr
17-Peridot
17-Peridot
(To:KimH)

@DeviVijayakumar Ist that confirmed, that no patch will be provided until the next CPS release? That can't be true, or?

I cannot confirm that it is working in HTTPS.

 

The issue occurs in both HTTP and HTTPS.

The issue occures in Google Chrome 83.x and 84.x (beta) and in MS Edge 83.x

@aacciano3 @KimH - I only have one user that is on the new Edge and this happened to them.  If I cleared his cache and then had him open the In Private browser for Edge he has no problems now.  We even closed it out and redid it a few times to make sure that it would still work.  I'm wondering if we need to switch to Waterfox/Firefox.  I heard that Firefox and Chrome were being mentioned as browsers of choice for Windchill 12.

@BrianToussaint , interesting that you can get it to work in Edge 83, by clearing the cache and starting in "In Private Mode". Unfortunately I am not able to reproduce this. It still does not work here.

Can you be more specific about the steps you have taken?

BrianToussaint
19-Tanzanite
(To:KimH)

@KimH All I had the user do was delete all his history and related items from Edge.  Close Edge and then he right clicked on the Edge icon in the task bar and selected to use the In Private browser.  He then opened Windchill and started working.  I had him try a CN multiple times through the point of failure that he was having in normal Edge.  Then we closed it and tried again.  I cannot get it to work that way in Chrome though.  Sorry that I do not have Edge 83 to provide screenshots.

Thanks @BrianToussaint , I will try to play around some more.

I guess, that as soon as the user opens Edge in a normal Window, it will be broken again? At least until the cache is cleared and Edge is started "In Private" again - Correct?

BrianToussaint
19-Tanzanite
(To:KimH)

@KimH - that would be my guess. Fortunately I only have one user on that browser right now so they know to open it in "In Private".

R&D has been working on this with priority and has identified a potential fix now. The fix is currently being tested.  After adequate verification, we'll look into back-porting to older supported releases based on technical and other considerations.

 

All of you have been testing various use-cases - A list of use-cases to test from this group will help speed up the verification. Thanks!

Issue here with:

  • Windchill 11.1 M020-CPS13
    • https
    • Don't use http so can't test
  • Chrome
    • 83.0.4103.97
    • 83.0.4103.106
    • Version 84.0.4147.45 (Official Build) beta (64-bit)
  • Edge - haven't tried it

Some other use cases that may or may not be mentioned in this are:

  • Deleting object from a workspace
  • Selecting existing object in workspace and then selecting the green + "Re-add existing object(s) in the workspace to update content." icon

User Case:
Chrome 83.0.4103.106
Windchill 11.1 M020-CPS08
Non SSL layer (HTTP) WIndchill URL

We are on:

11.0 M030-CPS13   HTTPS

Chrome 83.0.4103.106

Creo 4.0-m090

Reproduce problem:

  • Create/Edit a CN Chance Notice
  • go to second page implementation plan
  • Edit/Open Change task (where you would add CAD objects)
  • Spinning circle

 

Does not Work in following:

  • WC: 11.0 M030-CPS12 (not using HTTPS)
  • WC: 11.0 M030-CPS18 (not using HTTPS)

Above WC versions don't work in browsers:

  • Chrome: Version 83.0.4103.106 (Official Build) (64-bit)
  • Chromium Edge: 83.0.478.50 (Official build) (64-bit) 

Tried to no effect:

  • Clearing cache in all browsers as well as in Windows Internet setting.
  • Private browsing (though didn't know/try the trick to start in private mode shown by one user above)

 

Thankfully still works in IE!


"When you reward an activity, you get more of it!"

@DeviVijayakumar , do you need more use cases to proceed working on the fix?

Yes. While the software versions are helpful, I was also looking for the UI scenarios (like the Change Notice example). Thanks for checking back.

@DeviVijayakumar 

I have many UI examples I can show you.

If you would like contact me, all the details are on C15427851.

The list of cases listed in the SPR provides a good set of UIs to test on. Thanks!

I think I will have a hard time justifying to my management team, that we need to apply a Windchill update or maybe an upgrade project to fix an issue that occurs after an update to a web browser.

 

@DeviVijayakumar, It will be highly appreciated if you supply some more information about the root cause to this issue.

 

And by the way... I just tested the newest official build of Edge 83.0.478.54, which also the issue.

This is apparently a bug in the Chromium engine (Status of their bug - fixed in Chrome 85.0.4182.0)

View solution in original post

My Chrome just updated to 85.0.4183.83 and it is working again.

For me too!  My Chrome just updated to the same version (85.0.4183.83) and I verified the lightbox is now working on the ECN edit page of the define implementation page.

 

However, Chromium-based Edge has evidently not updated yet as it is still broken.  I am guessing that they will be soon to follow.

 

To @DeviVijayakumar and PTC, thank you for keeping us informed via this post.


"When you reward an activity, you get more of it!"

@lscheeler I don't know how much I would count on Edge in the future anyways as it isn't one of the browsers listed in the Windchill 12 documentation.  Only Chrome and Firefox are.

I just checked again and I think you are mistaken because it looks like MS Edge is now supported, although I think it is the newer Chromium-based Edge (and not the older clunky one).  This browser is basically chrome with a MS skin and log-in accounts.  It is actually quite nice (Although I miss IE for WC because of the unique and ease of selection using ctrl button).

 

See for yourself and let me know if I missed interpretted:

https://www.ptc.com/support/-/media/support/refdocs/Arbortext_Content_Manager/11,-d-,0/Windchill11_0...

 

 

 

 


"When you reward an activity, you get more of it!"
aacciano3
13-Aquamarine
(To:lscheeler)

Edge update was just pushed out:

 

aacciano3_0-1598558096488.png

 

Wow, Just is right!  Thanks for the notification.  I just tested and now it works correctly in Chromium-based Edge too!


"When you reward an activity, you get more of it!"
Announcements