cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Have a PTC product question you need answered fast? Chances are someone has asked it before. Learn about the community search. X

Display shaded datum plane

Greg_McMurray
6-Contributor

Display shaded datum plane

I just installed Creo 8.0.2. I have  "Display shaded datum plane"  selected and the config.pro option  "3D_datum_display_fill"  set to yes, but my datums aren't shaded. Anyone have any idea what I'm missing?

 

Greg_McMurray_0-1640809218582.png

 

1 ACCEPTED SOLUTION

Accepted Solutions

Also, you can rename all config.pro files to hide them for Creo, start Creo and create new part to see datum plane display. If filled datum planes are displayed then your problem is caused by config.pro option.


Martin Hanák

View solution in original post

16 REPLIES 16

 Hi,

 

Several solutions can be found in this thread - "When I disable the Plane Fill Display, the Datum doesn't refresh correctly": https://community.ptc.com/t5/3D-Part-Assembly-Design/When-I-disable-the-Plane-Fill-Display-the-Datum-doesn-t-refresh/td-p/740653 

 

P.S. From "Help Center" (configuration options associated with this functionality) - "Shaded 3D Datum Plane Display": https://support.ptc.com/help/creo/creo_pma/r8.0/usascii/index.html#page/whats_new_pma/ux-shaded_3d_datum_display.html

I'm aware of the bug regarding the datum planes only displaying the positive side color and not the negative when shading is turned off. There was an SPR filed for that.

 

But that's a different issue from mine. My problem is that I can't get the datums to shade at all. As you can see in the image, I have selected the datums to be shaded, as explained in Help Center, but they will not shade.

Hi,

please let us know what values are set for following config.pro options

3D_datum_display_fill
3D_datum_planes_transparency
spin_with_3d_datum_planes
enable_legacy_datum_planes

 

I guess that enable_legacy_datum_planes is set to yes.


Martin Hanák

Also, you can rename all config.pro files to hide them for Creo, start Creo and create new part to see datum plane display. If filled datum planes are displayed then your problem is caused by config.pro option.


Martin Hanák

That's it, thanks. The datums are shaded with an empty config.pro file.

 

I had 3D_datum_display_fill set to yes, 3D_datum_planes_transparencypercent set at 47%, spin_with_3d_datum_planes set to yes, and enable_legacy_datum_planes set to no. Something else in there is causing the problem.

 

Along with the new options they come up with for each new release, I wish PTC would also tell you which ones need to be deleted.

For the record and in addition to Martin's excellent solution, the config.pro option that was preventing the datums from being shaded was enable_opengl_shader. I deleted it from the file, and now everything is running smoothly.

enable_opengl_shader is set to YES by default. Typically you would set it to NO if you had or have graphics card issue that prevented its use.

I don't know that it matters but if you had graphics card issues, they could "reappear".

 

Thanks, my graphics card is a 4095MB NVIDIA Quadro P5000. There are no issues with it.

I'm switching back to Creo 7 until they work out all this nonsense.


@Greg_McMurray wrote:

Thanks, my graphics card is a 4095MB NVIDIA Quadro P5000. There are no issues with it.

I'm switching back to Creo 7 until they work out all this nonsense.


Hi,

you can add graphics win32_gdi into config.pro (using Notepad) and test Creo 8.0.2.0. If this setting resolves "invisible components" problem then the problem should be related to installed version of graphic card drivers.

You can remove the above mentioned option from config.pro and install different version of graphic card drivers.

Unfortunately P5000 model was not tested with Creo 8.0 ... see https://support.ptc.com/WCMS/files/175687/en/hp_creo8.pdf 

 

 


Martin Hanák

Yes, by the looks of that list my next step is try a different graphics card. Now that I think about it, in the past I've had problems in Render Studio seeing parts behind other transparent parts. The same type of thing must now be occurring with transparent datum planes.

 

Either upgrading to RTX or downgrading to P2200, this may be the first time ever that I submit a hardware downgrade in order to do a software upgrade.

I would be surprised if a Nvdia Quadro P5000 graphics card didn't work just fine since the P2000 (at least on some systems) is certified on Creo 8.

Creo Parametric 8.0 on HP hardware, Z6 workstation P2000 is supported.

 

StephenWilliams_0-1641395284732.png

 

I think it would be a matter of finding the correct graphics driver.

 

Now I see another problem. Some of the components in my assembly are completely hidden by the datum planes. When I hide the planes then I can see them. This occurs with the default empty config.pro file.

 

I'm beginning to think shaded datum planes aren't quite ready for prime time yet.

Is this a situation where no config.pro file means 0% transparency? Did you try to change the 3D_datum_planes_transparencypercent value to see if it behaves better?

mkajdan
14-Alexandrite
(To:KenFarley)

The default value for that option is 7 using the config.pro from the install with 0 being completely transparent.

mkajdan
14-Alexandrite
(To:Greg_McMurray)

If you have the config option blended_transparency set to YES or No, it will block components in your assembly.  Setting this config option to independent * which is the default setting will fix this issue, at least it did for me.

Greg_McMurray
6-Contributor
(To:mkajdan)

That's a winner. Solved! Mine was set to YES for some long-since forgotten reason.

 

This one seems kind of important. Definitely one that should've been added to the additional information config options in the help files.

Top Tags