cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Have a PTC product question you need answered fast? Chances are someone has asked it before. Learn about the community search. X

When I disable the Plane Fill Display, the Datum doesn't refresh correctly

Andrea3D
4-Participant

When I disable the Plane Fill Display, the Datum doesn't refresh correctly

I am using Creo Parametric - Release 8.0 (connected) 8.0 8.0.1.0

When I disable the Plane Fill Display, the Datum doesn't refresh correctly: if I turn the model from the positive datum Plane to a negative Datum plane view, the color of the Datum Plane remain the same until I turn off and on the Plane Display.
This issue is recurrent evry time I turn the model with Datum Display On without the Plane Fill Display.

This issue is present in the 8.0.0.0 and 8.0.1.0 too.

Here are the errors that I faced
no error nessages

4 REPLIES 4

Hi @Andrea3D,

 

Can you please check and confirm within your config.pro/config.sup if you are using config option 3d_datum_display_fill and what is the value that has been set?

 

Thanks,

Vipul

 

 

bmancini
13-Aquamarine
(To:Andrea3D)

Hi Andrea3D,
I have the same problem too.
I use the "3d_datum_display_fill" option set to "no", so no plane fill.
When I use the "Shaded" view, the classic yellow and red color of the border of the reference planes do not dynamically update as I rotate the model.
They only update if I turn off and reactivate the plans.
Instead they update correctly if I don't use the "Shaded" view....
Hope they fix it soon, I haven't installed datacode 8.0.0.2 yet.

Using Creo Parametric 8.0.2.0, I found that this works as intended if "enable_legacy_datum_planes" is set to "yes". But when set to "no" (or default) then it doesn't update the edges of the datums properly with shaded views.

 

EDIT: I accidentally mixed up "yes" and "no" when I originally posted this reply. It has now been fixed.

bmancini
13-Aquamarine
(To:TK_10053534)

Thanks TK_10053534!!!
I tried the option you identified and it works !!!
In my case, however, the "enable_legacy_datum_planes" option is set to "no" by default, by setting it to "yes" the colors of the reference planes are managed correctly even in shaded mode.

Top Tags