cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Stay updated on what is happening on the PTC Community by subscribing to PTC Community Announcements. X

Random connection error on a Protoolkit full async application.

sergio72
1-Newbie

Random connection error on a Protoolkit full async application.

Hello everybody, i'm experimenting a very strange connection error. I have
a full asynchronous toolkit application. It seems to works ok, connecting
to ProE session and doing what is expected to do, but sometimes it fails
to connect ProE session. When connection fails i try to restart the
application but fails to connect, over and over again. The only way to get
it working again is to shutting down ProE session, that means shutdown
xtop.exe process, and restart it. This is not a clean solution since the
user has to save all he has on current session, close ProE, restart ProE,
retrieve all models again and starts the toolkit. I want to know if it is
a xtop.exe issue or it is due pro_comm_msg.exe process and if anyone has
been experimenting connection errors like the one described. And if is the
answer is yes, how he has solved it?

Thanks in advance.
This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
1 REPLY 1

I too had faced this issue , tried lot of things but what could work as a solution is provide connection string as input argument to ProEngineerConnect() or ProEngineerConnectWS(). It assures connection to the proe session. nmsq -query would be helpful in retreiving proe session info. and creating a connection string.

Top Tags