cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Turning Program for Radius with R command instead of I, K

ptc-2781586
4-Participant

Turning Program for Radius with R command instead of I, K

I am making program using creo manufacturing and using CAM Post post processer to convert it in Fanuc controller program.

But machine is very old control system or something else is locked in machine, which is not able to read i, k command used in Radius turning step and only able to understand "R" command.

 

How can we make CL file which should have 'R' command instead of i,k command for radius machining in 2-axis turning machine?

3 REPLIES 3

I believe you would want to run Applications->NC Post Processor

Select the file that is your usual post processor.

Click on Motion->Circular

You hopefully will see something like the attached image. Where it says "Output IJK", click on the dropdown menu and there's an entry that specifies "Output Radius". That should fix things for you.

ptc-2781586
4-Participant
(To:KenFarley)

Hi,

I really couldn't understand

 

You mean, I still generate same CL file as usual, so nothing to do in Creo Manufacturing.

And this option you suggested can be done while I am generating my file in ICAM Post Processer?

 

If yes, I don't see same post processer or option, what you suggested!

I am using ICAM V18 post processer and there I don't see any option to change like this!

 

Can you please help!

We use the post-processor built into Creo to generate the ".tap" file (G-code) from the Creo generated ".ncl" file. We don't use ICAM or any other external programs to do this. The option I showed was what you get if you are modifying the particular post-processor you're using within Creo.

Your original post only said you were using CAM post-processor, which is a standard acronym for Computer Aided Manufacturing.

But anyway, as far as I know, the problem isn't something being caused by Creo. It's likely generating .ncl lines that look like

CIRCLE / 5.5590680, 0.9809165, -0.5000000,  $
0.00000, 0.00000, -1.00000,  1.4100000

Your troubles are being caused by how the post-processor interprets and translates this into G-code. There's got to be a setting somewhere in the software you are using that tells it you want either the IJK outputs or the R output.

Announcements