Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

The PTC Community email address has changed to Learn more.

Learning Connector issues (?)


Learning Connector issues (?)

Has anyone else been told by customer service that a script error in the Learning Connector is caused by Internet Explorer 9.0?

Twice now, a Java update has causes errors with the online help part of the Learning Connector. This is a fairly recent occurrence but very persistent. The 1st time I contacted CS and when they connected to my computer it magically fixed itself (something to do with remote desktop... or something else not disclosed)... anyway, a few days later, another Java update installed and the problem exists again.

This morning I get awoken to tell me that this is an IE9 issue and I need to downgrade to IE8 (This is a factory install of IE9 on Win7)...

Last time I tried downgrading IE I lost a bunch of functionality. It basically toasted my entire OS (Windows XP IIRC).

Is PTC really that far behind their programming efforts that they cannot even keep up with browser updates? Is their XML programming really that fragile? This just reflects very poorly on the fit and finish of PTC once again.

Anyway, anyone else get the same "solution" from PTC or CS?


If you have this issue, please post here.


In case some of you IT gurus can decifer the issue, this is the error that is logged in the Learning Connector:

Thu Feb 28 22:43:04 GMT-800 2013 com.ptc.labs.connector SEVERE: Timeout while calling Timeout while calling
at Unknown.Exception_0(Unknown Source)
at Unknown.TimeoutException_0(Unknown Source)
at Unknown.run_1(Unknown Source)
at Source)
at Unknown.anonymous(Unknown Source)
at Unknown.apply(Unknown Source)
at Unknown.entry0(Unknown Source)
at Unknown.anonymous(Unknown Source)


try to clean IE cache.

Martin Hanak

Martin Hanák

Thanks Martin. I'm afraid that didn't fix it.

Seems a more recent Java update corrected the Learning Connector error. Glad I didn't have to try to install IE8.

The Saga continues!

I get a wake-up call from CS... I again get told that IE9 is not supported. Yesterday, I was again/still having errors. After again requesting the information, I received an e-mail on how to uninstall the IE9 update assuring me that a restore point can bring me back to where I was. to top this off, I am asked to let CS know how it went! Shouldn't this process be vetted by CS 1st?!

We're going on 4 weeks now including an update to Creo and still no resolve? Is IE9 really that problematic that it is not mainstream? The Learning Connector is one of the applications that we pay maintenance for, right? Shouldn't -at least- that be kept current with IE?

And to top that, this afternoon, the Learning Connector is functioning again.

I'm sorry, but last time I uninstalled IE, my system became terribly unstable never to be recovered.

PTC, this needs to be acknowledged and fixed!

I'm not using LearningConnector so I'm unable to test, but if your error log is correct, you're getting a time-out requesting a JSON result of a search query - nothing to do with IE8/9/10 as far as I can tell, I'm not a great web programmer but I've seen some .js in my day. Any problems with your internet lately? Unless has been really slow lately, that shouldn't happen.

Thanks David. I honestly think the issue is on PTC's end. The problem is sporadic. When I query the failure I go to PTC with the failed link and get a page full of irrelevant search results, almost like a full buffer.

It is funny because PTC says their software is compatible with IE9, yet on the requirements for learning connector, it only supports IE7 and IE8. I say PTC needs to get its act together as the learning connector is a selling point for maintenance. It is really poor form for a company to take your money and not adequately support what you are paying for. I would be happy to help the development peeps if they just accept it. But the service tech hasn't submitted an SPR and told me it is a "known issue" but cannot provide me with an expected resolution date.

I am running IE on a cable modem and the PC is wired to the router at 100mb/s. There should be nothing on my end not functioning. Java is updated regularly with automatic updates.

I like having in-context help, but when it is not functioning, I have to minimize the help portion of the learning connector.

Hopefully this is the final note on the subject.

Yesterday I get an email from the elearning library team on my issue and they tried to tell me I don't have the elearning license... and I know that. And that is not the issue I reported... I ask again, do people really -read- our support cases thoroughly enough to understand the issue?

This morning I get a call to confirm that the issue was on PTC's end and that this is now resolved (YEA!).

So I go to the new support applet to see the resolution so I could report it here. What do you know, this case does not list in any of the supprt case applet! So now I have a new case to find the old case status

Anyway, thank you all for your help in this matter.



Apologies for the intermittent trouble with the help center in Learning Connector for Creo. We are working on investigating and resolving the root cause. We do know that it is not related to IE9. I will follow up with PTC tech support to make sure they have the correct information.

We will get this resolved as quickly as we can. Thanks for your patience and for reporting the issue.


Kim Springston

PTC University

Thanks for responding here, Kimberly. I re-opened the case this morning as well.

This use to be a real problem with network plot queue's as well. Seems something very similar is happening.

Back in the days when I've had active maintenance I was also told that elearning licence (PrecisionLMS) is required to run learning connector.

Couple of times I was able to run learning connector without with just the maint activated, but only some of the vids worked, some didn't wanna work. And what did work was mostly the basic stuff so I said "pfffffff", and never bothered with Learning Connector again.

Is it any good? When it does work.

It does require a PrecidsionLMS license and with maintenance, at least with my re-up the Windback elearning library was included. It is an extremely limited version of the elearning library with only the upgrade enhancement sessions. But you also get the Learning Exchange video library.

The only thing I found it useful for is some level of context sensitive help making it a little easier than the installed help search tool. What is really annoying is that the failure is from the same help resource as you have installed, except that it points to PTC's web site. And it makes you log into your account when you choose to explore a subject that it brings up. A choice to make the Learning Connector use the help files on my computer without logging in would is just about warranted.

Hello all,

Here is an overview of the 4 components in Learning Connector and what is needed to access.

  1. Video tutorials - no login or eLearning license required. The videos are played directly in Learning Connector. The tutorials are also included on Learning Exchange ( which is free but does require that you login with a account. No special privileges on your account are required.
  2. eLearning topics - an eLearning license is required to access this content. You will be prompted to login using your Precision LMS account, which is tied to your account, every 24 hours.
  3. Help Center - requires you to sign in with your account and the account must have a software maintenance entitlement on it. There is an initiative in the techncial publications groups to make the Help Center publicly accessible which will eliminate the account login. I believe this is planned for Creo 3.0.
  4. Knowledge Base - requires you to sign in with your account and the account must have a software maintenance entitlement on it.

Hope that helps clarify what should be happening. If you find your experience is different please open a case with tech support for follow up so we can investigate and fix.


Kim Springston

PTC University

That helps a great deal Thanks again, Kimberly!

I can't believe this is still an unresolved issue by PTC.!!!

Here I am almost 1 year later and I am dealing with the exact same scenario as Antonius. Same run-arounds, same hand-offs, pointing to everything else... I.E., Windows OS, a option called "enable_socialink" set to "no". All of these to still no avail. Nothing makes it work. PTC doesnt know what else to do. They drop the calls, etc... @ Kim Springton... we all know what PTC Leraning Connector is "supposed" to do.

I have performed hundreds (literally) of installs since Pro/E 16 (1994) and up to Creo 2.0 M080 and have never seen anything like this. A member group from Canada, who are staunch Solidworks users were forced to use Creo and they cant seem to get the Support, Help they require for the past two weeks. They're hating every minute of it. I find it unbelieveable. The competition between Solidworks and Creo is fiercer than ever, Im affraid to say that Solidworks sitll edges Creo by a long shot. And these users are determined to prove it. sadly enough.

Hi Frank,

I am sorry you have had difficulty trying to resolve this issue. Getting Learning Connector up and running shouldn't be difficult. You probably know this already, but when you contact PTC's technical support, be sure to get a call number. If you feel the support you are receiving is not helpful, you should escalate the issue. The TS engineer or the operator can help you do this.

I suspect the issue you are having is different than Antonius's issue because its root cause has been resolved for quite some time.

The issue posted by Antonius appears to be related to Learning Connector's communication to the Help Center. As mentioned, it has been resolved for quite some time. From the error messages mentioned early in this thread, I can see there is a ajax/JSONP timeout for a request from Learning Connector to PTC's Help Center. We also know that there is a syntax issue with the response from PTC's Help Center. Since there is a syntax error, the response is not seen by Learning Connector. These special case errors in PTC's Help Center responses have been resolved, so you shouldn't be seeing them today.

To clarify some of the items noted above.

  • Creo's Learning Connector does not use Java on the client, so Antonius' observation that the error occurred after updating the JVM is probably just a coincence.
  • I am not sure why it was suggested you set the option `enable_socialink` to `no`. It should not be relevant to Learning Connector.

If you are having problems starting Learning Connector here are some things to investigate:

  • If you don't see the Learning Connector button you may not have Creo Platform installed for your version of Creo. Creo applications such as Learning Connector communicate with each other through the creoagent.exe which is apart of the Creo Platform. Normally this is installed automatically with Creo's installation software. If you don't have it or it was accidentally uninstalled, you can install it manually: "<cd image directory>\install\addon\creoagent_32_64.msi"
  • Google Chrome Frame (a plugin for Internet Explorer) is not supported with Creo Learning Connector. You should uninstall it if you want to use Creo Learning Connector.

If Learning Connector is starting and:

  • you are having an issue like Antonius', where the help center is not responding or sending back an invalid (syntax error in response), then I believe it must only occur in rare/special cases. Technical Support should be able to help identify what is needed to reproduce the issue on their end so they can work to get it fixed.
  • If you checked the above, then you may have a firewall or proxy server that is blocking traffic to some or all of

I hope the above helps you make progress with debugging this. If you continue to have problems, please contact PTC's technical support and if necessary escalate the call if you don't feel you are getting acceptable support.

Darcy Parker

PTC University

I'm just going to come right out and say it... Someone at PTC needs to be fired. Apparently no one bothers to do their job anymore. What happened to accountability, attention to detail, customer service, and "going the extra mile" to make a good impression?

These are dying and outright dead concepts, aren't they?

Early today I opened a ticket with PTC Customer Support wondering why the Learning Connector (which was working recently) suddenly stopped working. The cause- Internet Explorer 11. That I can find, this information is available nowhere on PTC's website. This is maddening.

So Internet Explorer 11 for Creo 2.0 M100 is "supported" but not for the Learning Connector? We're using Creo 2.0 M100 and we expect that means all available services will also work with this tool.

Internet Explorer 11 was released on October 17, 2013. That's nearly a year ago... yet PTC was somehow caught flat-footed getting the Learning Connector to work with this browser? I guess Microsoft "sprang" it on them.

Ah- but certainly I'm just being a big jerk expecting PTC to keep in step with every release of Internet Explorer. I'm displaying a fundamental misunderstanding of the rigors and complexities of releasing software in the modern age, aren't I? I'm surely just being a fool, right? Way back on October 26, 2012, Microsoft released Internet Explorer 10 for general use. Of course the blasted Learning Connector must work for IE 10, right? Not according to customer support! The support tech tried to talk me into downgrading to Internet Explorer 8. I am not making that up. IE8 was released on March 19, 2009!

This is just unacceptable.

Integrated availability of help, training, and custom content was a major pillar of Creo 2.0's "ease of use and adoption". How in the world can this be flubbed so badly? And more importantly, how does this kind of thing keep happening. If Steve Jobs ran PTC, heads would roll for such epic fumbles.

I won't even bother going off on the rant of epic proportions Creo/Windchill interoperability has coming. An entire team of people need to be fired for that mess.

For things like this, someone really and truly needs to be fired.

Yes, fired. Not reprimanded. Not given a negative performance evaluation with ample opportunities for corrective action. Not retrained... just fired. Someone from HR needs to arrive at their desk, have them pack up all the cute photos of their kids and pets and loving elderly parents... and unceremoniously rip the badge from their shirt and escort them to the front door.

Ya know what's missing in corporations today? I've become convinced... it's fear. There's no fear of failure. There's no fear of losing your job. Employees sit around noodling on Facebook, calling their significant other, looking at cat videos, and just going about their day as if the job is just some inconvenience they must endure for a few hours. What's missing is any sort of passion for putting out a rock solid product, for crushing your competitors by beating the snot out of them in every possible way, and for true leadership and vision.

Someone at PTC needs to wake up. Quit buying new companies. Quit blowing wads of cash making changes to the software interface. Quit golfing. Quit putting more money into sales and salesmen than into product development and support. Quit valuing image and flash over substance, speed, and reliability.

And for the love of all that's holy... if you're selling interoperability, ease of use, and ROI then all of your products should work together before they are released. When I click a button on the screen, the button had better work. If your sales literature touts a feature, that feature needs to function right out of the box with no excuses.

There is absolutely no excuse why the Learning Connector doesn't work with Internet Explorer 10 or 11. No excuse at all... and someone needs to be fired.

Say what you really feel, Brian... go ahead, let it out!

This is the worst joke ever on PTC's part. I've even had the "responsible" person reply to me at one point to provide profuse apologies... yet, the problem continued on and off for the remainder of my subscription. It was really bad code that tripped up the dialog. And rather than fix it, they continue to blame M$.

Why not just build some robust code around it? Is it just one of those ignored children of PTC that doesn't get funded? Is it simply outsourced and managed as complaints come up? How do you get complaints when people simply give up on it.

I remember being very vocal about it and things changed for a short period of time. Almost like they left someone at the switch to manage choke holds on the server. Since PTC wanted more money for less services (yes, the learning connector is an OPTION of all things!), it seems they are simply shooting themselves in the foot by not standing behind the miniscule level of help that a user can obtain. At every turn, I learn more about Pro|E from this forum and other user resources than I do from PTC. Their promise for improved help is also a joke! Where did half the data go in the Creo 3 release? The search function is the same stone age engine used since the "release xx" days! WHAT!

PTC is digging its own grave like it has so many years now. We use this "thing" because we know it or our employers are still under the PTC spell. However, There is no sign that PTC values me as a single seat user. I simply see us being abused by both the VARs and PTC itself. Two price increases in as many years! For what? How long did Creo 3.0 take to get released? Did my customer support really improve? Did the software really get that much more robust or feature filled? To all these I can honestly say NO. Trust me when I say that the learning connector is the LEAST of my quibbles with PTC.

i will join it too...

i love the software uptil pro/e wildfire 4.0 i guess.

and creo i mentioned before...other than unite technology...which will come in M020...i just don't get can they release F000 without it..and keep saying about it.

they stopped our maintenenace mid-way..because we did not have 51% of licences under maintenance(new rule)

we have only two licenses by the way.they never informed us when we were buying the second licenese about this rule.

they just do not care for small sad actually.

the symbol creation for drawing in creo 3.0 is still a big joke.

names of datum plane in part and assembly mode is intersecting with the outline of plane (creo 2.0 & creo 3.0)..but who cares..

or the guys and PTC cannot see it.

they are still enjoying the benefits of the past glory..and they do not want to accept it.

one day that would end...

when we pay..i don't think there should be any excuses...none what so ever.....

I'm with you on many of these points, Antonius...

I struggle with what can be done about it though. I go to Technical Committee meetings, I do every single PTC User Experience Lab they offer to provide feedback, I work in the user community, I participate in the PTC Live Event, and I even talk directly with PTC folks behind the scenes. Yet except for a few notable exceptions, the large and overarching problems remain unaddressed.

When people see a PTC Product Line Manager or executive, they're polite and friendly. So few people will stand up and be seen as the 'troublemaker' that PTC rarely hears negative feedback. PTC employees might troll these boards but they usually don't respond. If you ask most PTC employees, they're genuinely shocked when you tell them their software doesn't work correctly or that you've had a bad experience dealing with others at PTC. Some of them are like "Moonies" for pete's sake.

"Diplomacy is the ability to tell someone to go to hell and they eagerly anticipate the journey". I apologize to the person who originally said this, but it gets my point across.

I would welcome the opportunity to talk with a PTC Product Line Manager or executive. I believe I could be polite and friendly, and still get my points across. Of course I sometimes use words like blunt objects.


I dream of this encounter.......

But from what I see on this forum, I don't think it would make much difference. If they're not listening to y'all, then obviously they don't care.

I thought I was being harsh, but then read the earlier posts.

Honestly, would you continue to drive an automobile that behaved the way this software/company does?

I guess that's what I am unable to get through my thick head, Jim... they do not care.

For some reason this just refuses to compute for me. I cannot bring myself to believe that these people honestly don't care when it's crystal clear they should. Which is how I arrived at the point in my previous message that no one seems to care anymore.

I spent two weeks at Disney in Florida just a few weeks back. "Best Customer Service Team on the Planet"... pfffft. Whatever. Once upon a time it used to be that way, not anymore. The same surly, entitled, self-absorbed jerks you find everywhere else were running rampant there. That's the big reveal... so many people in this country just can't be bothered to care about anything other than looking down at their cell phone.

I guess I just have a hard time believing a company can continue to exist with such sheer, unapologetic hubris. Apparently though, it can.


I am sorry about the difficulties you have had running Creo Learning Connector with IE11.

It seems you were given the wrong information by Technical Support. IE11 support was added for Creo Learning Connector in April 2014. As you mentioned, Creo 2.0 M100 is required if you are going to use Creo Learning Connector with IE11. This is because prior to Creo 2.0 M100 there was a problem with how IE10 and 11 were embedded. With the fix in Creo 2.0 M100, Creo Learning Connector could be updated and was updated April 2014.

So you should be able to use Creo Learning Connector with Creo 2.0 M100 and later and IE11. Since you are having problems, please contact Technical Support to work through the issue. Also, please note your call number so you can escalate the call if you feel the support continues to be inadequate. To escalate a call, you can ask the Technical Support Engineer to escalate the call and/or contact the Technical Support Operator and ask them to escalate the call number.


PTC University


Let's break this down for a moment. I called tech support and opened a ticket. They gave me an answer (one I didn't like) and politely hung up the phone. I came on PTC Community and flipped out.... and now you've responded that I got the wrong information.

How can I tell when I've gotten a bad answer? Should I reopen every single ticket I've ever opened with PTC and escalate it to see if I get a better answer? Have we now all become children demanding candy at the checkout line and then 'shopping' from parent to parent hoping to get an answer we like?

If PTC's support personnel cannot be trusted to give a correct answer, why would I ever bother calling them again? I rarely waste my time calling them for a Creo problem anyway. But when I do, the fact that PTC Customer Support is so tremendously and consistently terrible still amazes me. I've gotten calls from PTC before apologizing and trying to explain some support tech's blunder. The thing is... it's been happening since the mid 1990's and it hasn't improved.

But to cut to the chase:

The Learning Connector DOES NOT WORK with Internet Explorer 11. Period. I believe the support tech is, in fact, correct this time. The code being loaded when you attempt to run Learning Connector is incompatible with IE11. A method call that does not exist in IE11 is being used. I reported this, I gave screenshots of it, and I dug into the registry and verified it. The Learning Connector believes I'm running IE11 (which I am) and it is failing to start due to an invalid method call "attachEvent" which should have been replaced with "addEventListener" at IE11.

So it's broken. And... again... someone needs to be fired.

Or to be more precise... The Learning Connector does not work with Creo 2.0 M100 running Windchill 10.2 M020 (SSL encrypted) on fully supported hardward if the client workstation is using Internet Explorer 11. There is no workaround. You cannot force the Learning Connector to use any other browser other than IE. You cannot set any clever registry keys to force the Learning Connector browser to use IE10 or IE9 commands (compatibility mode).

The tool is simply not functional. See the error below...


This also does not work on Creo 2.0 M110 so please save the line about the need to upgrade to the latest build code. I am using the absolute bleeding edge of production software available... and this tool does not function. Reopening a ticket in the hopes of getting a better tech or a better answer is simply unacceptable.

Hey Brian,

I feel your pain on most of this as well. I have seen the same issues as well with IE 11, M110 and M100 with PDMLink 10.2 M010 and M020 when we tested.

However, we just went live with PDMLink 10.2 M020 CSP01 and now it works....So I am thinking that something must have changed in the CSP01...

I just happened to check after reading this.



I actually think it's the SSL encryption on Windchill that's somehow causing the problem but I'm not sure why this would be the case.

We have CSP01 and it still does not work. Are you using SSL for Windchill or not? If you connect to your server with an https:, you're definitely encrypted. Either way, it should work... why would WINDCHILL be messing with the Learning Connector in Creo?!

just showing http:

I agrees why should that matter? Odd.

I also just installed M120... no help.

It seems the only difference so far is that you run Windchill 10.2 M020 without SSL and I run it with SSL.

Mine is also significantly slower now that we've turned on SSL. Why? Who knows.