Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

The PTC Community email address has changed to Learn more.

Creo 1.0 M030 won't run

21-Topaz II

Creo 1.0 M030 won't run


I've installed Creo 1.0 on my machine (Win7 64 bit desktop), starting
with F000 and now bumping up to M030. With M030, I had to agree to 2 UAC
prompts when I launched Creo 1.0 for the first time, one for the
thumbnail viewer and one for the 'Creo platform'. These appeared after
Creo launched. I think this has been covered before. Annoying, but
once they are done Creo seems to run & launch fine after with no UAC

I'm rolling Creo 1.0 M030 out to my users so we are prepared when we
need it and on the first install (Win7 64 bit, laptop), Creo will not
even run. I've verified that my custom install batch files seem to run
fine with no errors, and even tried going to the install folder and
launching parametric.exe directly. I get the prompt to choose a license
configuration, but once I do - nothing. Parametric.exe or xtop.exe (is
that still valid?) do not appear in the task manager. I was logged into
the laptop with the domain admin account and it is plugged in to the
network. I get no error messages either.

Could this be related to the need for the UAC prompts? On my machine,
those did not come up until after Creo 1.0 launched, on the laptop I'm
not even getting that far.

Doug Schaefer

This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
Doug Schaefer | Experienced Mechanical Design Engineer

You may want to try installing the thumbnail view and creoagent on each machine. The msi's are here:
<loadpoint>\Creo 1.0\Common Files\M030\install\addon

You may also want to add this registry entry on the clients. (I didn't have to do this for Creo 2.0, not sure about Creo 1.0)
Check to see what it is on your machine. This is from Creo 2.0 so your mileage may vary.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\PTC\Creo Parametric\2.0\2012060]
"DisplayName"="Creo Parametric"
"InstallLocation"="C:\\ptc\\Creo 2.0\\Parametric"
"InstallDir"="C:\\ptc\\Creo 2.0\\Parametric"
"InstallSource"="E:\\Creo Parametric 2.0\\F000"
"CommonFilesLocation"="C:\\ptc\\Creo 2.0\\Common Files\\F000"

David Haigh

OK, based on suggestions thus far, I've tried:

* RMB on parametric.exe and selecting 'Run As Administrator'. No
* Installed the add ons directly from the <loadpoint>\Creo
1.0\Common Files\M030\install\addon folder. No change.
* Tried RMB on parametric.exe and selecting 'Run As Administrator'
again after running add on installs. No change

Any other ideas? I'll put in a call to PTC, but I can't do so until I
can get some access to his machine for an extended time period.

Doug Schaefer
Doug Schaefer | Experienced Mechanical Design Engineer

Had this same behavior on a brand new machine. (Creo 1 M020 and M030)

After a battery of tests, I called support. Exhausting the PTC side of the equation, we solved the issue by upgrading to the latest Nvidia drivers.

Since then, no issues (testing Creo 2 now).


2 suggestions:

1) Run Creo as administrator first time. This should install the 2 missing components.

2) You can set the environment variable APPL_STARTUP_LOG true.
This will create an applstarter.log file on C:\ showing what happens during launch of a given configuration, in other words, debug what happens during the execution of the .psf file.
You will need write access to the root of C:\ for this to work, so run as administrator might be helpful here too.


Hi Doug, Had something similar,

Had Creo 1.0 M020 installed, then did the upgrade to M030 and creo started
fine, Then run my batch scripts and creo wouldn't start, turned out that
one of my scripts still pointed to the M020 folder which was no longer

Also the Parametric.psf file needs to be for the correct datecode, mine
was from the m020 which also seemed to stop Creo running

Go figure!!

Best Regards

Chris Collinson
CAD Administrator