Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Learn all about PTC Community Badges. Engage with PTC and see how many you can earn! X

Creo 2.0 not working/ reagiert nicht


Creo 2.0 not working/ reagiert nicht

I installed Creo 2.0 on my PC and everything went well, untill I wanted to start the Programm.
Once i start it up it loads, opens up and i can see the normal UI, which one should see but Windows instantlly tells me that the programm isn´t responding and has to be shut down.I already tried reinstalling everything with the same result.


My system:

Windows 7 64bit

Intel Core i7-2670QM @2,20 GHz
Intel HD Graphics Family
NVIDIA GeForce GT 540M
and 8 GB of DDR 3 RAM


I hope somebody will be able to help!
Tank you in advance!







ich habe ein Problem mit Creo 2.0. Sobald ich es starte meldet sich Windows zu Wort und meint es reagiert nicht und muss deshalb geschlossen werden, obwohl ich im Hintergrund die normale Benutzeroberfläche sehe.
Habe es bereits komplett neu Installiert, ohne Erfolg.
Ich hoffe mal auf hilfreiche Tips.
Danke im Vorraus!


Hello and welcome to the forum, Ralf.

You will find tips on the forum regarding disabling OPENGL and using the native windows graphics mode. This is the 1st suspect in most cases. This simply means your graphics driver or hardware is either incompatible or not OPENGL compatible.

Of course, you cannot even open the program to understand the options.

First you need to modify a file. You also have to create a desktop shortcut to start in a different folder than the default.

This is the option description:


opengl*, x_windows, win32_gdi, d3d

sets the optional graphics environment used by certain platforms for running creo parametric.

to import files in snapshot tiff format into creo parametric, ensure that graphics is set to win32_gdi.

Make a file in your startup folder with the following line:

graphics win32_gdi

Call the file: (be sure the filename doesn't maintain a hidden .txt extension!)

Copy the default Creo shortcut on the desktop to something new.

Edit the new desktop shortcut; right click on the shortcut, right click and select properties.

Enter the full path for the location where the file resides in the "start in" field.

Now try starting Creo as before with the new shortcut.

This procedure bypasses OPENGL completely. If this works, then we have isolated the issue. If not, we move to the next step (if this is a new full version installation, that may be a customer support case which is always an options.).

Hi there,

thank you for the fast response!
I tried bypassing OPENGL but apparently this does not seem to be the issue, it still crashes after starting.

Are you using windows 7 pro?

No I am using Windows 7 Home Premium (64 bit)

That is likely the problem. All versions of Pro/E, WF, and Creo have required the professional operating system as a minimum until Windows 8. You might contact customer support to confirm.



in the past I installed ProE Widlfire 5.0 on Windows 7 Home Premium (64 bit). I hope that Creo Parametric 2.0 runs on this operating system, too (unfortunatelly I cannot test it).

I suggest to install Windows 7 Home Premium (64 bit) from scratch...

Martin Hanak

Martin Hanák
Top Tags