cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Learn all about PTC Community Badges. Engage with PTC and see how many you can earn! X

Creo View & Illustrate Open with too large font in GUI

jwiley
1-Newbie

Creo View & Illustrate Open with too large font in GUI

Hi All,

Is there a user_prefs.xml setting for the fonts and font size.

I have this in Creo Parametrics, but I fixed it in the config.pro file.

Like all the previous ProE versions I added these changes

menu_font arial, 12

popuphelp_font arial, 12

default_font arial, 12

What's the equivalent setting to be added in Creo View & Illustrate user_prefs.xml files

thanks,

Jim Wiley


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
2 REPLIES 2

Hi Jim...

Beyond the settings available in the Options menu inside of Creo View and Creo Illustrate I don't know that there are any other customization options. I think this may be one for PTC.

Please update us if you get a response. I have never seen anything like a config.pro for Creo View that does anything other than toggle the switches already available in the options menu.

Thanks!

-Brian

jwiley
1-Newbie
(To:jwiley)

Hi All,

Ok – It was fonts. We have a VM Win7 64 build that is a bare bones build that we copied the fonts from. It even had the international fonts loaded for around 260 font files. (Fixed Friday, 5 days ago - waited to see response from PTC support).

I just installed those fonts (right click – Install) – overwrote them in fact to make sure they were active. Then tested the installed Creo. It did not work. Un-installed it. Installed Creo Illustrate again – it worked. So the Installer is the failure point.

I don’t believe the fonts were actually removed. They were de-activated in Windows. It is was pretty much what I was saying was going wrong.

PTC support couldn't say when we asked about which fonts it looks for when it is installing. This is an old, old bug that we have seen for years now. At least the last 3-4 ProE upgrades I have had this problem that we always fixed in the Config.Pro file - including Creo Parametrics.

The required font or fonts need to be present and active during install. The installs on all the PTC programs like ProE and Creo have this challenge.
Whatever font or fonts that are needed by Creo exist in the default Windows font set.

We have thousands of fonts being a publishing group. If you do not deactivate some of those fonts, then the systems resources can get overloaded. XP the maximum number of recommended active fonts by our fellow publishers was around 200. Win7 is higher.

Publishing and multimedia people are candidates likely to use illustrate and they are most likely to de-activate fonts too. We need them to publish a list of required system fonts by OS version. Also a script could be made to activate the fonts too.

Admin's you might want to push them for a list of required system fonts. You could probably make a script to activate the fonts too.

Jim

Top Tags