cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - New to the community? Learn how to post a question and get help from PTC and industry experts! X

Is it possible to serve Creo 8 licenses from a Windows Server 2012 R2 machine?

ptc-198068
2-Guest

Is it possible to serve Creo 8 licenses from a Windows Server 2012 R2 machine?

Our team would like to begin using Creo 8 but I've been unable to upgrade our license server to support this version. Our license server is running on a Windows Server 2012 R2 machine and it appears that the new license server (Flexnet 11.17.1.0) required for Creo 8 doesn't support this operating system. Has anyone managed to work around this problem?
7 REPLIES 7
haizhang
15-Moonstone
(To:ptc-198068)

Hi, 

The final solution is upgrade Windows server to 2016 or 2019, which can guarantee to get official PTC technical support in any case you get license server problem.  

As a short-term work around you can try to install 11.17.1.0 directly or install 11.16.2.1 instead. NOTE: this is only for a short term work around, and please do enough test. Also think about final solution. 

Thanks for your reply. We will certainly look to upgrade our server in the future but it might take some time. I've tried installing those two Flexnet versions as a short term solution but in both cases the installer hangs at the point of reading our license file (or connecting to the existing license server). I assumed this was due to incompatibility with Windows Server 2012 but might something else be causing this installation problem?

You might also install/update Visual C++ Runtime Libraries. I recently did a test install of 11.17.1.0 on Windows 7 and I had to install Visual C++ 2013 and 2015 libraries (both x86 and x64), but that's what helped me to run this specific Flex version.

Thanks everyone for your help. I've now successfully installed the Flexnet 11.17.1.0 license server on our Windows Server 2012 R2 machine. I think my problem stemmed from the fact that I hadn't been able to uninstall the old license server (uninstaller was giving an error). Following a server reboot and after stopping the lmadmin_ptc service I finally uninstalled the old license server and then the new install went perfectly. In the meantime I had also installed the Visual C++ libraries suggested by LukaszMazur so this might have also played a part.
haizhang
15-Moonstone
(To:ptc-198068)

If the installer not woks, please also try to install Lmgrd version by referencing the Manual installation Suggested Technique as show:

Download link:https://www.ptc.com/support/-/media/support/refdocs/Creo_Illustrate/5,-d-,0/PTC_LMS_Download_121640.pdf?sc_lang=en

It's kinda hard to reference this manual installation technique, since the article has been retired and it doesn't seem to be a newer/alternative version of it:

LukaszMazur_0-1630911380500.png

 

haizhang
15-Moonstone
(To:ptc-198068)

Hi LukaszMazur, 

Thanks for sharing this possible solution.

 

Hi all, 

Sorry for the bad link. If you have a PTC account, you can review an related article for detail steps.

https://www.ptc.com/en/support/article/CS62129

Top Tags