cancel
Showing results for 
Search instead for 
Did you mean: 
Security Alert Log4j Security Vulnerability. Click here to know more.
cancel
Showing results for 
Search instead for 
Did you mean: 

Ratio Dims and 1 Decimal Place Rounding

dgschaefer
21-Topaz II

Ratio Dims and 1 Decimal Place Rounding

Creo 2, M220

Our client's default units are mm and their config file has default_dec_places set to 1.

With normal dimensions, within the feature creation the value rounds to a single decimal place, but if you edit the feature (not edit definition) you can type in a 2 or more decimal number and Creo retains the value, but displays it as one decimal place.

I'm having issues, however, with ratio dims, in particular the dims that place the radius points in a variable round:

Capture.JPG

I can drag those points and Creo gives me the 6 digit, somewhat random numbers above.  Creo seems to snap in roughly 0.05 increments, however if I enter 0.05 Creo converts it to 0.1, 0.25 becomes 0.3, etc.  I cannot enter in dims in smaller increments than 0.1 and I cannot drag in increments smaller than roughly 0.05.

In this case I need the fine control to put those points where I want. Is there a way to set Creo to ignore the default_dec_places setting for ratio dims?


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
1 ACCEPTED SOLUTION

Accepted Solutions

Found it.  I had this in my personal config:

default_dim_num_digits_changes no

I don't remember why I set it but removing it (the default is yes) fixed the problem.

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn

View solution in original post

15 REPLIES 15
TomU
23-Emerald II
(To:dgschaefer)

You will probably need to manually edit the number of decimal places for each of the dimensions when outside of the feature, then go back into edit definition and redefine.  (Similar to sketcher behavior.)

dgschaefer
21-Topaz II
(To:TomU)

I agree, but with a variable radius round, the point positions aren't available when you edit the feature, only the radius values.

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
TomU
23-Emerald II
(To:dgschaefer)

Hmmm.  Good point.  Just tried it myself.  With default decimal places set to '3' the number is never less than three digits but will expand up to six digits as the number requires.

I'm not seeing the automatic conversion from 6 digits back to 3 (for anything other than zeros)...

TomU
23-Emerald II
(To:dgschaefer)

I just tested this again while changing the default_dec_places value.  Here's what I'm seeing for these radius location values:

  1. The default_dec_places config option determines both the initial number and the minimum number of decimal places displayed.
  2. Values entered with more significant digits than the default_dec_places digits setting will maintain their full value, up through 6 digits.
  3. Values entered with more than 6 significant digits are rounded to 6 digits.  (This seems to be hardcoded and independent of the config option.)

Again, I'm not having any issue with 4, 5, or even 6 digit values maintaining their full number of digits, even with default_dec_places set to '1'.  By the way, this is with Creo Parametric 3.0 M100

dgschaefer
21-Topaz II
(To:TomU)

Hmm, that's different than what I'm seeing.  My experience is that dragging the point results in a 6 digit location (as seem in my image above).  If I enter a value longer than a single digit it gets rounded to a single digit.  So if I want it at 0.05, I get 0.1.  I cannot enter anything but 1/10 increments.

There must be another config option controlling this if you are getting different behavior.

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn

Is it possible you have round_displayed_dim_values set to yes?

Is it possible it is keeping your dimension values out to 6 digits but rounding the display?

I haven't explicitly set round_displayed_dims, so it is yes by default.

I'm using Creo 2, not Creo 3.

Testing the same files (config and part) with Creo 3, M100 gets me the same results.

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn

OK, it's something in my personal config file or the company.  I removed all config files from the loadpoint, launched Creo directly, verified no config files were loaded and loaded only the client config and the problem went away.

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
TomU
23-Emerald II
(To:dgschaefer)

Let us know if you figure out which config option is the problem.

P.S.  This reminds me of a quote from Mike Lockwood‌ earlier today:

All my life I've loved puzzles of all types - and spent considerable time on them.

Windchill is one of the best puzzles I've ever come across.

I guess we can extend that sentiment to Creo as well. 

Found it.  I had this in my personal config:

default_dim_num_digits_changes no

I don't remember why I set it but removing it (the default is yes) fixed the problem.

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
TomU
23-Emerald II
(To:dgschaefer)

default_dim_num_digits_changes
yes*, no
Sets the default number of digits in a dimension to the last entered value. If you set this option to no, the system defaults to the value specified for the configuration option default_dec_places.

There is another option that I think controls your offset value, try ratio_grid_interval and see if that snaps to a smaller value.

dgschaefer
21-Topaz II
(To:Kevin)

Removing "default_dim_num_digits_changes no" has fixed it. 

I don't have ratio_grid_interval set anywhere, but it seems to default to 0.05 which would explain the interval when I'm dragging the points.  It would not explain why it rounds to 0.1 intervals when editing adn probably wouldn't fix what I'm seeing.

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn

We don't have it in our config files but defaults to .05. It does show up when you look under All Options in the Config Editor. You're correct it shouldn't have anything to do with the rounding issue. There are a couple of places to find the settings. As far as I know the config options get applied to model creation (start part creation if you use one) so once that happens you then need to work with the settings in the dimension properties dialog. You change the settings there and they should ignore the 1 decimal place just typing in more decimal places doesn't necessarily change it to the number you specify, although if I remember correctly there is an option for overriding the number of decimal place or there use to be, I'd have to look it up. Un-selecting the round dimension value in the dialog box should round and truncate a value to the specified number of decimal places.

TomU
23-Emerald II
(To:dgschaefer)

My second round of testing was with a clean install of Creo 3 M100.  By the way, the default value for "round_displayed_dim_values" is "yes", and I haven't changed it.

Announcements