cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

persistent hidden layers, assemblies and components

ptc-5493477
1-Newbie

persistent hidden layers, assemblies and components

Something has changed. I have no idea what. Hope y'all can help.

I try to live by the admonition :"save early and save often"

When I hide a layer or component or assembly, it remains hidden when I re-open the file. This used to not be the case -

I swear, I have NEVER saved layer states. Really. NEVER, EVER.

I renamed my config.pro file (old_config.pro) so the stock config.pro file is loaded (I hope).

The behavior persists.

Any ideas? What have I done?

Creo 2.0 M010

 

Thanks!


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
1 ACCEPTED SOLUTION

Accepted Solutions

Resolution was (you're gonna love this):

1.burn the config.pro files

that didn't work - hidden models were still persistently and perversely hidden

2. re-install creo (what fun! only took the whole afternoon! another day ***poof!***)

This seemed to chase the goblilns away. Or maybe it was the phase of the moon. Or sunspots.

Anyway, it's back to what passes for normal now.

View solution in original post

11 REPLIES 11

It depends. How long have you been using PTC CAD?

PTC changed the behavior at least as far back as Wildfire. Before that Hide was a transient, unsaveable change. Then PTC merged it into layer management and made the Hidden layer permanently, well, Hidden. This meant that no Save Layer Status was required, but I think it stinks, as there is some benefit to an unsaveable transient visibility status. Like not ever having to worry about making an accidently state change that affects drawings and upper level assemblies.

I guess create a mapkey that performs Unhide All and then Saves.

Six months. And if I can't fix this, maybe not much more .

How can I save this mess so that when I (or someone else) opens it, the models aren't hidden?

You can always delete those layers and unhide everything you expect to see. Then save the layer status.

That's a dffferent problem - same release, changed behavior?

Use Info on the components and see what layers they are on. Then check the layers and see if the components are placed there by rule.Hide/Unhide in the model tree should add and remove them from the Hidden layer, if that's the layer they are on.

If that's not it, it may be a problem internal to the model that might be cleared up by simply opening it with a later version of Creo.

I for one have resorted to always start with an "empty" part or assembly. No auto-layers and frilly behavior.

Things do still hide on their own when I use a sketch for an extrude, for instance; or I create a datum on the fly (within a feature) and it then hides itself once the feature is complete.

Layer states that I specifically change always reverts if I forget to save the status.

Jim,

Creo 2.0 M010 is VERY OLD maintenance release and it is "unfinished". I suggest you to move forward and use more recent maintenance release. Current maintenance release is M110.

Martin Hanak


Martin Hanák

Have you tried right clicking on "Layers"and going to "Reset Status", just to make sure it hasn't been saved by some default magic that PTC has invented?

Hi Jim,

Let us know if this is still an issue or if you resolved it. Also please mark one of the posts as "Correct Answer" if applicable. Otherwise, mark your own response as correct if you figured it out on your own.

If this is still an issue we should confirm it is something being done by your machine or if another user is making the change and saving the status.

  1. Open a model
  2. Hide a layer
  3. Save and Close the model
  4. Erase Not Displayed
  5. Reopen the model

If Hidden status upon retrieval, there probably something in your config.pro. Perhaps your administrator changed the start-up script and adds a config option

  1. Click File > Options > Configuration Editor
  2. In the top right of this dialog box, click Display Filters and confirm "Current Session" is showing.
  3. In the bottom right of this same dialog box, click Export per Current Filter
  4. Save this file to your desktop and open it in a text editor
  5. Cut and paste the content of this file here as a respone in this discussion

Resolution was (you're gonna love this):

1.burn the config.pro files

that didn't work - hidden models were still persistently and perversely hidden

2. re-install creo (what fun! only took the whole afternoon! another day ***poof!***)

This seemed to chase the goblilns away. Or maybe it was the phase of the moon. Or sunspots.

Anyway, it's back to what passes for normal now.

View solution in original post

At least you didn't have to reformat your drive

Thanks for posting the solution!

You realize, from now on, every question you bring could be answered 'Did you reinstall first? '

With any luck that won't be the answer you need. Good to see it sorted out. Is it the same version?

Announcements