cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Create Dataset fails

SOLVED
skef
11-Garnet

Create Dataset fails

Hello,

 

the following error is occurring, when I try to create a new Dataset with analytics v. 8.3.040507:

 

Execution error in service script [CreateDatasetAMS] :: Error returned from service [500]: Unexpected error occurred:Unable to parse queuedStartDateTime: 2018-10-23T11:50:15.174Z]

 

How can I fix this error?

1 ACCEPTED SOLUTION

Accepted Solutions

The error was caused by sufficient folder permission. The related error message was logged in the /opt/twxanalytics/data/logs/data.log

View solution in original post

9 REPLIES 9

Hello,

I will be assisting you with this.

Can you please check if the zookeeper is in the running state or paused state?

 

Thanks

 

Best regards,

Prakhar Shubham

Hello,

 

thanks for your fast reply. How can I check this?

Hello,

Can you please provide below information:

  1. Are you using a VM or native installation?
  2. What operating system are you using?

Thanks 

Best Regards,

Prakhar Shubham

I am using a native installation, on a Linux machine

I think zookeeper is running, since the analytics things (DataThing, ResultThing etc) are running and 

 

ps aux | grep zookeeper

 

tells me, that there is a java process running which is related to zookeeper

Hello,

You can try running the below command and see if zookeeper process is running or not:

sudo /opt/ThingworxAnalyticsServer/bin/twas.sh list

OR

sudo /opt/ThingworxAnalyticsServer/bin/twas.sh status 

 

Kindly adjust the path according to your installation path.

 

Thanks

 

Best regards,

Prakhar Shubham

 

The service twas-zookeeper is not running / fails to start...

 

# service twas-zookeeper status

● twas-zookeeper.service - ThingWorx Analytics - Zookeeper
Loaded: loaded (/etc/systemd/system/twas-zookeeper.service; enabled; vendor preset: enabled)
Active: inactive (dead) since Mi 2018-10-24 08:06:05 CEST; 34s ago
Process: 12636 ExecStop=/opt/ThingWorxAnalyticsServer/zookeeper/bin/zkServer.sh stop (code=exited, status=0/SUCCESS)
Process: 12575 ExecStart=/opt/ThingWorxAnalyticsServer/zookeeper/bin/zkServer.sh start (code=exited, status=0/SUCCESS)
Main PID: 11504 (code=exited, status=1/FAILURE)

Okt 24 08:06:04 Laptop-036 systemd[1]: Starting ThingWorx Analytics - Zookeeper...
Okt 24 08:06:04 Laptop-036 zkServer.sh[12575]: ZooKeeper JMX enabled by default
Okt 24 08:06:04 Laptop-036 zkServer.sh[12575]: Using config: /opt/ThingWorxAnalyticsServer/zookeeper/bin/../conf/zoo.cfg
Okt 24 08:06:05 Laptop-036 zkServer.sh[12636]: ZooKeeper JMX enabled by default
Okt 24 08:06:05 Laptop-036 zkServer.sh[12636]: Using config: /opt/ThingWorxAnalyticsServer/zookeeper/bin/../conf/zoo.cfg
Okt 24 08:06:05 Laptop-036 zkServer.sh[12636]: Stopping zookeeper ... /opt/ThingWorxAnalyticsServer/zookeeper/bin/zkServer.sh: line 182: kill: (12595) - No such process
Okt 24 08:06:05 Laptop-036 systemd[1]: Started ThingWorx Analytics - Zookeeper.

I was able start the service twas-zookeeper.

 

twas-zookeeper.service - ThingWorx Analytics - Zookeeper
   Loaded: loaded (/etc/systemd/system/twas-zookeeper.service; enabled; vendor preset: enabled)
   Active: active (running) since Mi 2018-10-24 08:22:27 CEST; 20s ago

 

But the problem still exists. I am also getting the error message, when I try to use other twas microservices like CreateModelAMS:

 

[message: Execution error in service script [CreateModelAMS] :: Error returned from service [500]: Failed during training

The error was caused by sufficient folder permission. The related error message was logged in the /opt/twxanalytics/data/logs/data.log

View solution in original post

Announcements