cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Need to share some code when posting a question or reply? Make sure to use the "Insert code sample" menu option. Learn more! X

Thingworx Webapplication error.

MF_10165907
4-Participant

Thingworx Webapplication error.

Hello, I am having some troubles with thingworx. I followed a video installation, but for some reason I get the blank page that says page unavailable when trying to open composer. I checked the logs and it says the following:

2022-01-21 15:07:46.195-0600 [L: ERROR] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [P: ] [T: localhost-startStop-1] *** CRITICAL ERROR ON STARTUP: Failed to create com.thingworx.persistence.postgres.PostgresPersistenceProviderPackage. Cause was due to 'null'
2022-01-21 15:07:46.195-0600 [L: ERROR] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [P: ] [T: localhost-startStop-1] *** Web Application STATE is being set to ERROR! ***

 

In my platform settings I have the following:

 

{
"PersistenceProviderPackageConfigs": {
"PostgresPersistenceProviderPackage": {
"ConnectionInformation": {
"acquireIncrement": 5,
"acquireRetryAttempts": 3,
"acquireRetryDelay": 10000,
"checkoutTimeout": 1000000,
"driverClass": "org.postgresql.Driver",
"fetchSize": 5000,
"idleConnectionTestPeriod": 60,
"initialPoolSize": 5,
"jdbcUrl": "jdbc:postgresql://localhost:5432/thingworx",
"maxConnectionAge": 0,
"maxIdleTime": 0,
"maxIdleTimeExcessConnections": 300,
"maxPoolSize": 100,
"maxStatements": 100,
"minPoolSize": 5,
"numHelperThreads": 8,
"password": "password",
"testConnectionOnCheckout": false,
"unreturnedConnectionTimeout": 0,
"username": "twadmin"
},
}
}
}

 

Do you know what the null value error means?

2 REPLIES 2

 Hi,

 

Read the following articles:

slangley
23-Emerald II
(To:MF_10165907)

Hi @MF_10165907.

 

What version of ThingWorx are you installing?  And are you installing manually or using one of the installers?

 

I don't think we have a current video for installation, so most likely it doesn't apply to the version you're installing.  Instead, you should use the instructions from the Help Center located here.  Be sure to check the System Requirements for the relevant version before beginning your installation.

 

If you can provide more details of your installation, I can possibly be more specific about the solution.

 

Regards.

 

--Sharon

 

Top Tags