cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Thingworx doesn't Create a License Request File

Shashi_Preetham
16-Pearl

Thingworx doesn't Create a License Request File

There are two weird situations,

1. When connected to a previous DB, without the license_successfull.bin, the TWX Shows "License expires in 326 Days".

2. But same instance if connected with another DB, it shows errors related to the License.bin file is missing.

Thingworx Version: 9.3.2.

@PaiChung @slangley 

Thanks,
Shashi.

Shashi Preetham (psp316r)
4 REPLIES 4

Hi @Shashi_Preetham 

 

We would need to check the ApplicationLog.log immediately following a restart (located in \ThingworxStorage\logs), but if the successful_license_capability_response.bin file is missing (in your 1st scenario), ThingWorx is reading the licensing info from the trusted storage. 

 

In regard to the 2nd scenario, do you have the keystore files from the original ThingWorx instance that was connected to this database--\ThingworxStorage\keystore.pfx and \ThingworxPlatform\keystore-password?  These files will need to be restored as well.  The Device ID is most likely different so a new license file will need to be generated.

 

Regards.

 

--Sharon

Hi @slangley ,

Thanks for the reply. In both cases, all the folders (ThingworxPlatform, ThingworxStorage & ThingworxBackup) are empty, except the platform-settings.json, even though still THINGWORX shows the license is installed and valid for 323 days without any file(Successful and request file) in ThingworxPlatform folder.

No idea what's going on. Is this because of the cache, or is there something stored in the DB?

In the same environment, the subscriptions are not invoking; it may be the same license issue.

Thanks,
Shashi.

Shashi Preetham (psp316r)

Hi @Shashi_Preetham.

 

Sorry for the delay.  I've been on vacation.

 

It sounds like we'll need to open a case so an engineer can review your system.  I'm happy to open one on your behalf if you're still experiencing problems.

 

Regards.

 

--Sharon

Hi @slangley ,

We can open a case for this, this behavior is observed only in the 9.x versions.

Thanks.
Shashi.

Shashi Preetham (psp316r)
Announcements