cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Time Series Charts does not show right data after modification of template

Malior
7-Bedrock

Time Series Charts does not show right data after modification of template

Hi,

I have the folloing situation:

- I've installed some sensors, sending temperature, pressure and humidity.

- I made a mashup, showing the temperature in time series charts.

- Everything worked fine.

 

Now we added airQuality to the sensors to send. So I added this field to the thingTemplate, my sensorThings inherit from - updated my service to write this as well. Everything looked working fine.

 

Now the issue:

All my time series chars now show the airQuality value, insatead of temperature.

Even when creating a new mashup, setting it up and make one field to temperature... shows airQuality instead.

And it is not a refresh problem from my browser. I can set the DataLabel1 to something - and it will appear... but still show wrong data.

 

Can someone help me please!!

 

4 REPLIES 4
PaiChung
22-Sapphire I
(To:Malior)

Potentially something got cached? did you try a full refresh (CTRL + F5) of the mashup?

it may not be truly saving your changes is another possibility.

 

Malior
7-Bedrock
(To:PaiChung)

I already tried

- I also tested from another machine, that was not yet connected to thingworx.

- And I restarted my thingworx server even.

- Created a totally new mashup, with new time series chart.

- Only the "LED Display" shows right data.

 

This is currently really an issue, as all my collected data became worthless now.

 

EDIT:

I've deleted the airQuality field. And everything worked again. I've then "re"added a quality-field.

Now, all my charts can only again show temperature...not quality, not pressure or humidity. Everything and everywhere I see temperature...

 

PaiChung
22-Sapphire I
(To:Malior)

That is very strange, does it behave like that if you add a field with a different name?

Malior
7-Bedrock
(To:PaiChung)

If I name the field, I get this name shown. But the data is still wrong.

 

But I've found a workaround. I have to set different data sources for each column by unchecking "SingleDataSource".

Announcements