cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

URL and APPKEY

Highlighted
Marble

URL and APPKEY

Hello All,

 

I was using the cloud version of thingworx, and now moved to local installation.

 

In the cloud one, I used to start my work by running an agent file with the URL address of my account such as below:

 

URI=wss://PP-2007161840G0.devportal.ptc.io:8443/Thingworx/WS

and add the APP KEY.

 

Now I know how to get the APPKey but not sure how to use as URI for the local installation.

 

Should I use: URI =http://localhost:8080/Thingworx ??

 

Best,

Ahmed 

8 REPLIES 8
Highlighted

Re: URL and APPKEY

Hello,

 

I tried to use the URI as below,  but I got the fetal error attached. Any idea?

URI=http://localhost:8443/Thingworx

 

 
 

 

 

 

Highlighted

Re: URL and APPKEY

I am attaching the error log file

Highlighted

Re: URL and APPKEY

Hi @Ghandour.

 

Please provide the logs located at \ThingworxStorage\logs.  These should provide more information regarding whether ThingWorx is running successfully.  If there are no logs at that location, please provide the following:

 

  • <tomcat_home>\logs
  • platform-settings.json located at \ThingworxPlatform

Regards.

 

--Sharon

Highlighted

Re: URL and APPKEY

Hi @slangley 

 

Here are the logs file and the error file I get as well.

 

Thanks a lot in advance.

 

Ahmed

Highlighted

Re: URL and APPKEY

http://localhost:8080/Thingworx/composer 

 

This is just a webpage.

Is your TomCat running?

 

Highlighted

Re: URL and APPKEY

Hi @bot1q 

 

I am not sure, how can I check that?

 

 

Highlighted

Re: URL and APPKEY

Hi @bot1q 

 

Is that what you mean? if yes, then I have it and it is runnung but still same issue

 

 

Ghandour_0-1598314699149.png

 

Highlighted

Re: URL and APPKEY

Hi @Ghandour.

 

It appears there is a problem with java.  You have installed a supported version, but given the errors it's returning, there may be some corruption. 

When you initially installed it, were you using an Administrator account?

 

Please also provide some details regarding your environment.

 

  • What version of Windows are you running?
  • Is it 64-bit?
  • Did you install the JDK or just the JRE?
  • How did you install the product?  Manually or with the installer?  What was the filename if the installer was used?

Thanks.

 

--Sharon

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum!