Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Recent Chrome Update Possibly Affects Windchill


Recent Chrome Update Possibly Affects Windchill

This is more of a post letting others know what I encountered today with my Chrome-Windchill connection, but if anyone knows what is going on that would be great to know.  It seems that Chrome recently updated their browser, mine is showing 83.0.4103.97, and I am now having issues with it.  I have cleared all the history out of Chrome and it still has the issue.  The issue has been seen across multiple computers, is that during the creation of a CN, when you go in and edit the task during that creation a blank window pops up with the spinning circle of death.  I am on Windchill  The only error that is in any of the logs is:

2020-06-05 07:51:47,667 ERROR [ajp-nio-] com.ptc.windchill.enterprise.change2.tags.ChangePropagationTag <USERNAME> - action oid was null


I have opened a support call and am waiting to hear back from them.


I don't know if anyone else has seen this yet or not.

123 REPLIES 123

It seemed that the early documentation for 12 had pointed to that.  I remember looking at it when this all started to see what long term options might be.  I just went and checked the document for 12 and see that it was revised 2 weeks ago.

5-Regular Member


Hello BrianToussaint,


The chrome version 85 is also out for our organization and major reported issues are solved :

Post update I performed the following check:

  • Creating a New Change Task 
  •  Save As of object
  •  Viewing Constraint of Attribute 
  •  Revise

Issues are still occurring in Edge Chromium version Version 83.0.478.64.


Please refer Windchill Future Platform Support Summary for the current state of support for Chromium-based Edge browser.

According to SPR 10134786 it will be fixed for all Windchill Version in the next CPS! 
the only problem we have is, that CPS 14 for Windchill 11.1 will be released end of July. That‘s in one month! So I guess all customer need to switch to Firefox or Mac Safari 🥳


Assuming X-26 = 11.0 it looks like CPS19 will fix the issue, but we have to wait 2 months for the release. On top of that we will have to buy extended support 😞


I hoped for a simple patch to solve this.


Anyway, is it confirmed that this is a Windchill issue and not something that eventually also will find its way to Firefox, if we switch browsers to get a quick fix?


Can somebody briefly describe the root cause for my understanding?

Same error happening for our user here.


Windchill 11.0 M030 CPS 06

Running in HTTPS

Chrome 83.0.4103.116

@DeviVijayakumar what's the status. Will there be a hotfix or do we have to wait for a month until the CPS will be available?


Anyone with technical insight to the issue who can tell if switching to Firefox is a long term fix, or if we risk the same issue in a future Firefox update

Chromium bugs list says that this may have been fixed in Chrome 85.0.4182.0.

Has anyone tried on this version? 


If this is a Chromium bug, what are you fixing with the CPS Release then?

Chromium closed their bug only last Thu. Until then we were not sure about when they'll have a fix. The fix we added was basically one of their recommendations.


We'd also like to avoid shipping a patch. 



  • Initially PTC hoped for a browser fix to make this go away.
  • Then PTC acknowledged that the issue has to be fixed in future CPS updates.
  • Now PTC is back and hoping for a browser update.
    ...... But still have not shared the root cause for the issue in this thread, or any articles related to the issue.

We are running in circles in our companies out here, re-evaluating our upgrade plans, browser policies, etc, to figure out how to make this go away.


If PTC has any respect for them selves, at least test this internally and let us know what to expect. In the compatibility Matrix it says that Chrome versions newer than version 57 is supported. I hope you will live up to that promise by being proactive in testing future versions.



We do understand your concerns and this is exactly why we’re trying all possible options to solve the problem at the earliest.

  1. We did not want to wait until Chrome fixes their problem when we had the option of providing a fix that will help you make progress.
  2. Now Chrome has a fix, and so we want to make everyone aware of it so that they can plan accordingly. We’re also simultaneously verifying Chrome’s fix.
  3. We reach out to this community, as an informal, collaborative effort, to evaluate all viable options for solving or alleviating the issue, and for providing updates as we’re working on solutions to critical issues discussed here.


I have installed Version 86.0.4187.0 and verify that the issues are not there anymore!

However, I cannot understand when this Chrome version will be out as production release.

Has anybody an idea?




Just tested a few of our usecases in respectively Chrome (Dev) 85.0.4181.8 and Chrome (Canary) 86.0.4187.0

I can confirm that the issue still persist in 85.0.4181.8, but not in 86.0.4187.0
So, it looks like something happened 🙂


Not sure if Edge (Chromium) is supposed to have this fix in versions newer than 85.0.4182.0 as well as Chrome? Do you have a link to the Chromium changelog about this fix?


I also tested with Edge versions 85.0.552.1 (DEV) and 85.0.562.0 (Canary), where the issue still persists.

I will test again when any of these Edge channels have caught up to 85.0.4182.0


Happy to learn that this can be fixed without applying a CPS 🙂

Now, we can't wait for the stable versions of Chrome/Edge version 85 to be released.

Chrome: 25 August

Edge: Hopefully close to August 25 as well.

Thanks 🙂

5-Regular Member


Hello Garnet ,

Is the scenario of Spinning wheel happen for ECN in Chrome version 85 as well?

Did you tested in WT_11.1 M020 CPS13 or CPS14.


As we are facing similar situation and need to plan if along with the Browser update the latest CPS Patch also need update?


Also the Chrome version 85 is supposed to be released in August 15,2020 according to the chrome blogpost.


I have downloaded and installed Google Chrome Canary from here

Version 86.0.4187.0 (Offizieller Build) canary (64-Bit)


The problem is NOT reproducible there!


I don't see version 86 listed there.  I only see 83, 84 & 85.

It lists the DEV version 85, but if you download and install, it's the Canary version 86


Ah.  I see.


I will wait until it's at the stable status.  I don't think my company would appreciate me downloading a development version.  Especially since we can use IE for now.

Hello all,


No one have mentioned that PTC published workaround to solve the issue.

if google fix the problem in the browser then the workaround should be reversed.


PTC Case CS326191 describes the workaround. I tested it and it works.


Best Regards



I also tested and it works. We will put into production this weekend.

note: Every user has to force refresh (control F5).

i'm holding out for the chrome fix and/or the installation of CPS14 to cure this. the work-around needs to be implemented now and then removed when chrome gets to the fix version in production. i only wan to fix this once.


@ScottMorris do you know what CPS14 will fix it? Isn't that the same workaround as described in the case? Just OOTB?


not sure yet. we just started installing CPS14 yesterday and hope to do some testing today

i can confirm this issue is not fixed in WC 11.1 M020 CPS14 using chrome v84

google chrome stable release for v86 is currently listed for early OCT!

ugh, back to sit and wait two more months for a fix 😞






I finished the installation of Windchill 11.1 M020 CPS14 and I have to confirm that the issue is still reproducible.

clearing the cache is done 🙂 


Chrome version  84.0.4147.105 (Official Build) (64-bit) - this provides details on how to manage this situation, if necessary, until the Chrome fix is released.

I'm a bit confused with the expectation that CPS14 provides an OOTB fix. Neither the SPR nor this article say that. Can someone please point me to the source of confusion so that it can be fixed? I'd rather not have everyone waste time on this verification, expecting this to be fixed in CPS14.