Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - You can Bookmark boards, posts or articles that you'd like to access again easily! X

sBatch & PlotDate corrupted Pro/E

21-Topaz II

sBatch & PlotDate corrupted Pro/E

WF4 32, Windows7 64

OK, so I downloaded and installed sBatch and PlotDate, formerly from
Spekan now part of the 'uTools' suite of Pro/E utilities from USG
Innotiv Product Development. I've heard good things about sBatch
specifically, and I've used sPurge for some time, so I wanted to give
them a try.

Well, this morning Pro/E would lock up at launch. I noticed that I now
have a 'uTools' menu showing and there was a splash screen from USG at
start up as well. I decided to uninstall them both.

Now, while Pro/E will launch, it has interfered with the batch files
that I use to run a trail fail at start up to load client configs via a
mapkey. The mapkey still works if I run it manually, so I assume that
the trail file isn't running for some reason. Also, I still have the
'uTools' menu and I still get the splash screen and I still have the
uTools menu. It's not in my file, I've checked the date
stamp on those. Lastly, at startup I get this error message:

And I have this in my std.out file:

A pre 18.0 Pro/DEVELOP application "Spekan" was found.

For faster startup please add "REVISION 0.0" to C:\Program
Files\proeWildfire 4.0\text\protk.dat

How do I remove the rest of Spekan from my machine and restore the
running of my trail files at startup?

Doug Schaefer

This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
Doug Schaefer | Experienced Mechanical Design Engineer

Hi Doug,

I simple method to remove the splash screen and uTools startup is to remove the following entries from the protk.dat (located at <proe_loadpoint>\text):

name uTools
startup java
java_app_class uTools
java_app_start start
java_app_stop stop
allow_stop true
delay_start false
java_app_classpath D:\ptc\proe31\text\java\uTools.jar

Note: the entry REVISION 0.0 is used by PTC to activate faster startup (from WF5 on)

Best Regards,

Martein Schuttert

Team Leader Services Product Development

USG Innotiv

Top Tags