cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Mail Server couldn't connect. Not getting configuration?

SOLVED
Highlighted
Regular Member

Mail Server couldn't connect. Not getting configuration?

Hello,

I have recently imported the Mail Server Extension (v3.4) in to Thingworx v9.

Configuration of the inherited Thing is:

SMTP Server name configured, SMTP Server Port 25, no authentication

 

When manually invoking the SendMessage Service I get the following error message:

Unable to Invoke Service SendMessage on MailServerThing : Couldn't connect to host, port: localhost, 80; timeout 30000

 

This says to me that it's still trying to connect to SMTP server on the local machine through port 80, despite the configuration.

 

Any ideas?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: HRe: Mail Server couldn't connect. Not getting configuration?

Update.

After installing the latest version, restarting the Server cleared the error above.

 

Thanks

View solution in original post

5 REPLIES 5
Highlighted

Re: Mail Server couldn't connect. Not getting configuration?

OK, so I upgraded the extension to v3.6 and am now getting.

 

ErrorCode(3592ead1-52d2-4fc4-b846-e66318a8b506), Cause(null), Reason(Access was attempted on a null reference variable.), Possible Resolutions(Remove the reference to the null variable within your extension code.)

Highlighted

HRe: Mail Server couldn't connect. Not getting configuration?

Hi @DKinlough ,

I have gone through the same problem. Looks like the old version is not working anymore on TW 9.0 because the initialization method has a different signature.

Before TW 9.0: 

                        protected void initializeThing() 

From TW 9.0+: 

                        protected void initializeThing(ContextType contextType) throws Exception {

 

I am attaching the updated extension but it is not covered by any license and it's not official.

Highlighted

Re: HRe: Mail Server couldn't connect. Not getting configuration?

Please have a look to the official extension shared in the PTC support website on the download software page for TW 9:

https://support.ptc.com/appserver/auth/it/esd/product.jsp?prodFamily=TWX

 

in the group "ThingWorx Mail Extension".

Highlighted

Re: HRe: Mail Server couldn't connect. Not getting configuration?

Hi @DKinlough.

 

If you feel your question has been answered, please mark the appropriate response as the Accepted Solution for the benefit of others with the same question.

 

Regards.

 

--Sharon 

 

Highlighted

Re: HRe: Mail Server couldn't connect. Not getting configuration?

Update.

After installing the latest version, restarting the Server cleared the error above.

 

Thanks

View solution in original post

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum!