cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Syntax errors on running twPostgresDBSetup.sh

SOLVED
Highlighted
Newbie

Syntax errors on running twPostgresDBSetup.sh

I have setup the Postgres DB in Red Hat Linux Machine. I have also followed all steps as mentioned in the pdf : http://support.ptc.com/WCMS/files/170230/en/Installing_ThingWorx_7.1_1.2.pdf

But while running the TW Postgres DB setup script mentioned in step 14, I am getting syntax errors.

Please let me know how to resolve the issue. The Thingworx, ThingworxPostgresqlStorage and ThingworxPlatform have been created in the same location as mentioned in the document

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Syntax errors on running twPostgresDBSetup.sh

Running the following two commands from postgres bin directory showed that there were some rpms from 8.4 postgres installation in the OS path. Removing them resolved the issue.

./psql postgres

\set

\q

psql -q -h localhost -U twadmin -p 5432 -v database=thingworx -v tablespace=thingworx -v tablespace_location=/app/navigate/ThingworxPostgresqlStorage -v username=twadmin

\set

View solution in original post

7 REPLIES 7
Highlighted

Re: Syntax errors on running twPostgresDBSetup.sh

What are the actual errors?

Highlighted

Re: Syntax errors on running twPostgresDBSetup.sh

I am getting syntax errors - syntax error at or near ‘:’ when i am running the script for all cases like creating tablespaces, database,etc.

Highlighted

Re: Syntax errors on running twPostgresDBSetup.sh

To me that sounds like there is an error in one of the files you had to customize.

Highlighted

Re: Syntax errors on running twPostgresDBSetup.sh

I am getting the same error. I have customized any thing and running the installer as is. Any idea how to proceed?

Highlighted

Re: Syntax errors on running twPostgresDBSetup.sh

Sorry. I meant I have not customized anything.

Highlighted

Re: Syntax errors on running twPostgresDBSetup.sh

Was the issue resolved for you?

Highlighted

Re: Syntax errors on running twPostgresDBSetup.sh

Running the following two commands from postgres bin directory showed that there were some rpms from 8.4 postgres installation in the OS path. Removing them resolved the issue.

./psql postgres

\set

\q

psql -q -h localhost -U twadmin -p 5432 -v database=thingworx -v tablespace=thingworx -v tablespace_location=/app/navigate/ThingworxPostgresqlStorage -v username=twadmin

\set

View solution in original post

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum!