Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Need to share some code when posting a question or reply? Make sure to use the "Insert code sample" menu option. Learn more! X

Non-Admin Users Unable to Create Entities

5-Regular Member

Non-Admin Users Unable to Create Entities

Hi all, 


I have a several users that are in the developer group so that they are able to publish to the connected ES. 


Along with this, it was my intention that they be able to create, edit, etc entities without giving them admin privileges. 


However, they are totally unable to edit, view, or create entities, even within projects to which they belong. 


Any thoughts on how to update those permissions?


I want the users to be able to able to create/edit/view entities within their projects without having everyone be an administrator. 


This is a cloud portal thingworx instance on 8.4.1


Hi @aouellet ,


I think this is strange , so far I know developer should be able to publish and this means also to create a new widget (Vuforia Studio) Because Studio creates mostly  the widgets offline (only if there are any twx data will try to update but it  will still continue also when the connection fails) therefor I think the described situation is a little strange.

But when first time I tested it , I was able to  reproduce the problem.... but actually  it was caused because  I tried the publish an experience which are create as admin user . This means if the admin user created some TWX entities or studio widget then seem to have a problem

When I created a new experience with a user which is member of the developer Thingworx group then it was working. I was able to publish first time. Then add a new widget and republish it again - this worked

I tested with Vuforia Studio 8.5.5, Experience Service ("version":"8.4.0-b792") and   ThingWorx 8.4.1-b2126 

I tested with  the following steps:

-added an user e.g. developer to the members of developer user group




Then I  created  a new experience as developer user (member of TWX developer group) .

Published it and then created a new widget,

saved it and republished it again -this was working:




So when I check the project on the server - I could see the new widgets are updated:




Because I was connected to the Experience Service as  admin to  open some files for check , then  one time I received an error and publish did fail.

... But when I  unpublish the experience from servier (as developer)




Afterword’s it was working again - I was able to publish the modified experience / Studio project.

So I believe your issue is caused mainly  when the experience  project is edited  also form users which are members of the admin group and published. Or in some case it  access Thingworx entities  in the External data section where the developer group user has no write permission for the design time


Top Tags