Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Want the oppurtunity to discuss enhancements to PTC products? Join a working group! X

gpost (apparently) omits first feed rate


gpost (apparently) omits first feed rate

there appears to be something wrong in my Gpost Config.  The NCL clearly shows the first feed rate, but the posted ngc is missing it.  seems likely to be a problem in gpost. Mine is a simple 3-axis FANUC post modified to work with LinuxCNC which is the controller for my little mill. 

Where would you look for this problem?


The NCL File:

$$* Pro/CLfile Version 7.0 -
$$-> FEATNO / 15355
$$-> CUTTER / 0.092000
$$-> CSYS / 1.0000000000, 0.0000000000, 0.0000000000, 0.0000000000, $
0.0000000000, 1.0000000000, 0.0000000000, 0.0000000000, $
0.0000000000, 0.0000000000, 1.0000000000, 0.0000000000
SPINDL / RPM, 2600.000000, CLW
FEDRAT / 3.000000, IPM
GOTO / 0.0000000000, 0.0000000000, 1.0000000000
GOTO / 0.6750000000, 0.8718272424, 0.1250000000
CYCLE / DEEP, DEPTH, 0.192640, STEP, 0.009200, IPM, 3.000000, CLEAR,$
0.006000, RETURN, 0.125000
GOTO / 0.6750000000, 0.8718272424, 0.0000000000
GOTO / 0.6750000000, 0.4568272424, 0.0000000000
FEDRAT / 3.000000, IPM
GOTO / 0.6750000000, 0.4568272424, 1.0000000000
GOTO / 0.0000000000, 0.0000000000, 1.0000000000
$$-> END /

The ngc File:

(DATE:01/14/21 TIME:09:06:15)


Accepted Solutions

no errors no warnings.  If there's any comfort in any of this, I've found after many years of doing stuff I didn't fully understand that I'll eventually prevail if I remember what I've already tried so as not to go into a loop, and NEVER give up.


thanks for keeping an eye on this,


View solution in original post

23-Emerald II

Which product is this?

this is done by the Gpost which comes with Creo 7.0 Manufacturing.  I'm pretty certain that problem is something I did in configuring the specific post I'm using because other posts do not omit the feedrate at this location.  I suppose that a person who is pretty familiar with Gpost may recognize where I went wrong.  

The difficulty is that you are showing people the input (.ncl) file, and the output (.ngc?) file. There are multiple processing steps taken between the two that are the cause of your troubles. Without information about what the settings are for these steps no one is going to be able to determine what's gone awry.

Did you edit the .FIL code (files with name like uncx01.f01, uncx01.f02, etc.) to attempt to do what you need?

Presumably you made some sort of changes to the settings of the post processor via Applications->NC Post Processor. What did you change?

If it were me, I'd compare the setup that's causing problems to one of the others that is working fine, see what is different and try switching the likely suspects and test the results.

Thank you for this response which is clearly correct. I did the modifications using Gposts GUI. I have not so far been able to understand the files you refer to.  I suspect that there really is more than one way I could have induced this problem and it was something I did with the post. 


I need to improve my vocabulary enough to rehears whay I did so that the problem I had with the original post ican be seen and then, hopefully how better to deal with it.  


Bear with me. It will take a day or two of messing with this to get back to you with something you can work with.john

It's never any fun trying to figure out what's going wrong with GPOST. Particularly bad is when the program is output fully but certain things are not okay.

Wherever it is that you are writing your G-code files, you can look for a file called <your-program>.lst, where the <your-program> is the name of the NC file you are creating. It lists, line by line, each line from the .ncl file (the input) and the results of it being processed. Sometimes this can be enlightening as to the start of the troubles. Often it just ends with an error message, but that might not be the case for you.

no errors no warnings.  If there's any comfort in any of this, I've found after many years of doing stuff I didn't fully understand that I'll eventually prevail if I remember what I've already tried so as not to go into a loop, and NEVER give up.


thanks for keeping an eye on this,


Hi Ken,

I think I fixed it.  Rather than trying to puzzle out where I'd messed up the post which omitted feed rates, I started over again with the Haas V8 post and edited out the things it did that my controller couldn't recognize. It does work now.


So my last question is, which of the various post files should I print out to determine where the differences are in the hopes of identifying where I went wrong on the other post?


I still have work to do, but at least now, I can run a file and get what I want without a lot of editing.

Thanks much,



There are two places I look for how things are going to be processed. The first is the post processor editor that you've already experienced, where you desperately try to find the subsection of settings that will fix your problem. I believe the file that is written by this has a file name of the form uncx01.d##, where the ## is a two digit integer, like 01, 02, etc. That file is just a long list of numbers, not really anything in it that is easily deciphered, i.e. there's nowhere I can look in it to find out if I've got four digits after the decimal place for X values or whatever.

Paired up with this file is one with a name of the form uncx01.f##, where the "##" matches the uncx01.d## file. This file is what is called the FIL code. It's programming code to handle things that aren't done to my liking, so for specific action identifiers in the .ncl file it takes control, so to speak, and formats the g-code as directed. i.e. for your situation you might have it handle things when a FEDRAT/ command is encountered. The FIL code is where I do all my customization for specific machines. For example, we have a machine that, if given certain G codes, like G49, just ceases operation. Whereas other machines *need* that code to home properly, etc. Editing the FIL code is like any other programming language, except testing code is kind of a beast. You post process your code, then sift through the .lst file that is generated to figure out what is wrong.

It's cool when it works, but debugging is somewhat unpleasant.

Hi Ken,

One of the features of LinuxCNC is that it does a visual simulation either while outputting code to the machine or not.  It seems pretty sensitive to aberrations in the G-Code and it's objections are usually decipherable.  SO I can put fresh g-code through the dry version at home, and then have a better idea what it will do at the shop. It is better at language and formatting errors than discovering missing feed rates.  with the prior, you get the squawk when you load.  With the latter, it squawks when it gets to the missing feed rate.  


It is also very well documented.


Mine is not a revenue environment so the only real cost of confusion is time.  At 78, I am sensitive to this, but there is some satisfaction in finally getting something sorted.


Thank you for your help.  When I eventually get it, I'll post my error.

Top Tags