cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Need help navigating or using the PTC Community? Contact the community team. X

intelligent fasteners issue

sschwerin
1-Newbie

intelligent fasteners issue

Greetings all,

So I am attempting to use intelligent fasteners and am able to do so except when it comes to trying to insert 1/2". When I finish defining a screw fastener from the inch catalog with the hex bolt screw, 1/2" thread, and click ok a dialogue box pops up labeled intelligent faster with the following text in the box: "Customizing parts is not available in the standard version. Please contact your account manager to upgrade".

However, if I choose any other thread size I do not encounter this issue and a screw is inserted into the model. I don't see any issues in the .dat or .mnu file but I wouldn't put it past me to overlook something simple.

Any ideas?

V/r

Steve


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
6 REPLIES 6
StephenW
23-Emerald II
(To:sschwerin)

If Toby Metcalf‌ moved this to Intelligent Fastener Extension - IFX, you'll likely get better help.

Thank you Stephen Williams‌ I will move it.

Toby

TomU
23-Emerald IV
(To:sschwerin)

Have you used the 1/2" size in the past?  If so, did you modify it in any way?  (Added parameters, resaved it, etc.?)  Are you using Windchill (or any other PDM type system to manage files?

sschwerin
1-Newbie
(To:TomU)

I first stared exploring this feature a couple days ago and I'm pretty confident it did work then. I explored adding parameters so that these would work with our formats but can not see any permanent changes to the original .dat or .mnu files. I deleted all instances in my projects working directory and erased object current and not displayed. No other systems being used, just Creo on Windows.

sschwerin
1-Newbie
(To:TomU)

So, I figured out a solution. Somewhere along the line I changed the relationship between the axis and surface ID # so I went back into the hexbolt.prt model and matched the ID numbers with the .dat file and now it seems to be working.

TomU
23-Emerald IV
(To:sschwerin)

Perfect!

Top Tags