cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Distributed Batch

RonGrabau
5-Regular Member

Distributed Batch

I have a question about distributed batch.  I need to import several thousand parts that are SolidWorks parts and assemblies.  I want to use the distributed batch to convert the files to Creo Parametric.  I have no issue getting the batch to run and convert the files but I need to have the files read our templates. This way the files will be compatible with our draiwng formats and other function.  I see that there is a line within the batch file for configuration files and point to the config.pro that has the template file options set but this does not correct the issue.

 

Does anyone have a solution? Can I use distributed batch and have it work like a manual import?  By the way, manually importing files works as I would expect.  Thank you for the help!

1 ACCEPTED SOLUTION

Accepted Solutions

Ronald,

You can create a import profile and set config option intf_in_profile_default pointing to profile. When working in Distributed batch specify the config file under configuration options.  

View solution in original post

3 REPLIES 3

Hi,

I think you can use trail file to do the task.

MH


Martin Hanák

Ronald,

You can create a import profile and set config option intf_in_profile_default pointing to profile. When working in Distributed batch specify the config file under configuration options.  

View solution in original post

RonGrabau
5-Regular Member
(To:Mahesh_Sharma)

Thank you for your help on this issue.  This was the correct answer to my issue.  For those like me who do not know what a profile is or how to create it here is some more information.

Start Creo Parametric (I am on 3.0 M130)  but don't open any objects

Expand the Utilities and Pick the Import Profile Editor

It seems that this does read my config.pro because I have the correct template files for Part and assembly but (and a big but) the Use Templates is not checked by default.  All I had to do was check the option and save the file.

Now I can point the config.pro option to this saved file and all is working as expected.  Thanks PTC for the help and solution!

Announcements