cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

GPU usage in Simulation Live

SOLVED
kdirth
Peridot

GPU usage in Simulation Live

My understanding is that Simulation Live uses the GPU to perform calculations.  When I run a simulation on a part, task manager shows the CPU running hard and the GPU not doing very much.

 

Is this normal or is there a setting that I should look at to allow the GPU to take on some of the work?

 

CREO 4.0

GPU:  NVIDIA Quadro P4000
• Version 86.4.a7.0.d
• Memory ~25 GB


There is always more to learn in Creo.
1 ACCEPTED SOLUTION

Accepted Solutions

Re: GPU usage in Simulation Live

Hi kdirth,

 

I have a P4000 card and CSL runs well with it.  With some types of geometry (thin walled), it is possible for the CPU to so much of the work with the GPU only contributing a little.  This will drastically change with an improved Ansys solver in our next builds of Creo.  In this solver, the GPU usage will increase and get much closer to the memory limit of the graphics card. 

 

There is a small possibility that a setting is incorrect on your card.  If you look at the NVIDIA control panel and select 'Manage 3D settings', you can find Power Management mode and make sure it is set to  NVIDIA driver-controlled.  Almost all of the time, the default settings work for Creo Simulation Live.

 

If you still continue to have issues, please email me offline and we can get together and troubleshoot the issue.

 

Thanks,
Todd Kraft

CAD Product Manager

tkraft@ptc.com

View solution in original post

3 REPLIES 3

Re: GPU usage in Simulation Live

Hi kdirth,

 

I have a P4000 card and CSL runs well with it.  With some types of geometry (thin walled), it is possible for the CPU to so much of the work with the GPU only contributing a little.  This will drastically change with an improved Ansys solver in our next builds of Creo.  In this solver, the GPU usage will increase and get much closer to the memory limit of the graphics card. 

 

There is a small possibility that a setting is incorrect on your card.  If you look at the NVIDIA control panel and select 'Manage 3D settings', you can find Power Management mode and make sure it is set to  NVIDIA driver-controlled.  Almost all of the time, the default settings work for Creo Simulation Live.

 

If you still continue to have issues, please email me offline and we can get together and troubleshoot the issue.

 

Thanks,
Todd Kraft

CAD Product Manager

tkraft@ptc.com

View solution in original post

Re: GPU usage in Simulation Live

Hi,

you write that "This will drastically change with an improved Ansys solver in our next builds of Creo.".

Does this mean that new solver will be available in Creo 7.0 and also in Creo 6.0 and Creo 4.0 ?


Martin Hanák

Re: GPU usage in Simulation Live

UPDATE:

Everything is working as designed.  I was not viewing Cuda on the card.  Cuda does ramp up to about 80%.

Waiting for CREO 4.0 M130 to see the improved solver.


There is always more to learn in Creo.
Announcements