cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you get an answer that solved your problem? Please mark it as an Accepted Solution so others with the same problem can find the answer easily. X

Disabling _touchup in specific gentexts

JeffStevenson
2-Guest

Disabling _touchup in specific gentexts

Is there a way in FOSI to disable_touchup PIs in specific gentexts? I can disable it in specific contexts, but this disables it across the document. My gentext is coming from a ufe which cannot be used as a context in an e-i-c to my knowledge. Has anyone selectively disabled _touchup PIs in some gentexts by not others?



Thanks!

5 REPLIES 5

One of my stylersheets has the following e-i-c in a FOSI edited source:

<e-i-c gi="touchup" context="*" _sfe:headerorfooter&quot;=" gitype="pi">

This is a very, very recently upgraded from 5.3 to 6.0 stylesheet so I
can't comment on how reliable that coding is but it suggests to me you
could probably achieve what I think you're aiming for. (Whether in 6.0 you
have to do it in FOSI edited source is another discussion to have with
someone here who has been there, done that.)


On Wed, Sep 5, 2012 at 8:32 AM, Jeff Stevenson <jstevenson@gpslsolutions.com<br/>> wrote:

> Is there a way in FOSI to disable _touchup PIs in specific gentexts? I
> can disable it in specific contexts, but this disables it across the
> document. My gentext is coming from a ufe which cannot be used as a context
> in an e-i-c to my knowledge. Has anyone selectively disabled _touchup PIs
> in some gentexts by not others?
>
>
>
> Thanks!
>

If you are using Styler, there are checkboxes on the context dialog for
whether you want to include UFEs and/or SFEs in the context hierarchy:







I'm assuming that if you choose that option, and then export the
stylesheet as FOSI, you'll get something that looks like Paul's sample.



(This is with 6.0, M050. Not sure whether this is supported on earlier
versions.)



--C



Clay Helberg

Senior Consultant

TerraXML


Hi Clay,


If I check the boxes, they don't remain checked in the context I'm working in. Do you know why these would uncheck themselves?


Thanks,


-Jeff

Hi Jeff--



As far as I can tell, it only preserves the checks that you actually
use. In other words, if you don't specify a UFE or SFE in the context
selection, it won't keep the corresponding box(es) checked.



Basically, checking the box makes sure the UFE/SFE elements show up in
the droplists that you use to add elements to the context hierarchy, for
as long as the dialog is open.



So I guess you'll just have to manually check the box each time you want
to add a formatting element to the hierarchy. I don't know of a way to
change the default behavior to make them stay checked.



--Clay





Clay Helberg

Senior Consultant

TerraXML


Thanks, Clay! I was able to create the proper context.

Top Tags