cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

We are restricted to DTD 3.27 for a gov't project. We get an error where entries in the original xml files of: Maintlvl "field" and wpinfo "new" are not accepted by arbortext. How can we fix this?

dannajee
1-Newbie

We are restricted to DTD 3.27 for a gov't project. We get an error where entries in the original xml files of: Maintlvl "field" and wpinfo "new" are not accepted by arbortext. How can we fix this?

Hello,

We get errors when entries inside the the original xml files of:   Maintlvl = "field" and, wpinfo = "new" are not accepted by Arbortext.  How can we fix this?

This is not an issue on 2 of our PCs.  The other 4 PCs use a reinstalled ArborText application. 

All PCs are set to use DTD 3.27 for this project, it's mandated by the customer for this phase of the project.

Any help is greatly appreciated.  My direct e-mail is Delores.Annajee@ubtus.com

1 ACCEPTED SOLUTION

Accepted Solutions
TimPhelps
5-Regular Member
(To:dannajee)

<?xml version="1.0" encoding="UTF-8"?>

<?xml-stylesheet href="xslfo-main-v1_9.xsl" type="text/xsl" media="print,pdf" alternate="yes"?>

<!--Arbortext, Inc., 1988-2015, v.4002-->

The above should would be what you need at the front of your document.

The first line defines the document as an XML document.

The second line associates a style sheet to be used for Print and PDF composition.

The third identifies that the document was written by Arbortext Editor.

I see in our document

<?xml-stylesheet href="xslfo-main-v1_9.xsl" type="text/xsl" media="print,pdf" alternate="yes">

<!--Arbortext, Inc., 1988-2013, v.4002-->

Note: that your document is missing a question mark at the end of the first line it should be

<?xml-stylesheet href="xslfo-main-v1_9.xsl" type="text/xsl" media="print,pdf" alternate="yes"?>

Regarding pointing Arbortext Editor to find the correct dtd rather than browsing, see Arbortext Editor's Help center.

See the discussions about the CUSTOM directory and the environment variable APTCATPATH.

View solution in original post

5 REPLIES 5
TimPhelps
5-Regular Member
(To:dannajee)

Do the 4 computers have the same Entities paths as the other 2 computers?
What are the errors that you are receiving?

What versions are being used on the set of 4 versus the set of 2?

We found that some extra spaces caused a parsing problem.  Those errors are mitigated, but there are still issues with the files we were given.

Each time we attempt to open a file, it prompts for the location of the DTD.  How can we set Arbortext to point to the location automatically?

Also, an xml file (reply for a sample file) will pass completeness, but, will not produce a pdf.  We are publishing using the EMS NG publishing engine.

We were told that Arbortext expects an sgml,  and that the following line, placed first in the file, is supposed to force Arbortext to expect xml

<?xml version="1.0" encoding="UTF-8"?>    

  But with that line, the file will not load at all.

Delores.Annajee@ubtus.com

TimPhelps
5-Regular Member
(To:dannajee)

<?xml version="1.0" encoding="UTF-8"?>

<?xml-stylesheet href="xslfo-main-v1_9.xsl" type="text/xsl" media="print,pdf" alternate="yes"?>

<!--Arbortext, Inc., 1988-2015, v.4002-->

The above should would be what you need at the front of your document.

The first line defines the document as an XML document.

The second line associates a style sheet to be used for Print and PDF composition.

The third identifies that the document was written by Arbortext Editor.

I see in our document

<?xml-stylesheet href="xslfo-main-v1_9.xsl" type="text/xsl" media="print,pdf" alternate="yes">

<!--Arbortext, Inc., 1988-2013, v.4002-->

Note: that your document is missing a question mark at the end of the first line it should be

<?xml-stylesheet href="xslfo-main-v1_9.xsl" type="text/xsl" media="print,pdf" alternate="yes"?>

Regarding pointing Arbortext Editor to find the correct dtd rather than browsing, see Arbortext Editor's Help center.

See the discussions about the CUSTOM directory and the environment variable APTCATPATH.

View solution in original post

rdiaz
5-Regular Member
(To:dannajee)

Hi Delores,

Did Tim's information help you out?

Let the Community know if you need help, or found a good resolution.

Thanks!

dannajee
1-Newbie
(To:rdiaz)

Yes Mr. Diaz

I attempted to reply on Tuesday.  Somehow I sent the following to the wrong email address:

Hi Mr. Phelps,

Yes, after declarations of xml, not sgml, and fixing "PIs" the problems went away.

PTC Case C13049053  has been resolved.  Thanks for all your help!

  1. D. Annajee
Announcements