cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

processing Xref in Arbortext IETP Services Version 4.4 M010 (006)

Highlighted
Participant

processing Xref in Arbortext IETP Services Version 4.4 M010 (006)

Good afternoon.

I use a version of Arbortext IETP Services Version 4.4 M010 (006)
In this version I have problems with links to hotspots in the legend.
With the latest version they have changed.

I have more than a week trying to understand the mechanism of how they work.
And I had a few questions. Maybe someone knows or knows
someone who can answer me this question.

Firstly the file figurePanel.jspx
For legends exist the following code

<lbs: translate id = "translatedLegend"
xml = "# {figure.currentFigure.legend}" pub = "# {index.selectedPub}"
xsl = "# {index.styleSheetPath}" isoview = "# {index.iso}"
dir = "# {index.directory}" />

As used index.styleSheetPath descriptSchema.xsl
In descriptSchema.xsl imported a lot of styles. The question of what piece of code
responsible for processing the tag XREF. I used to have style xref.xsl
Now what happened to him that without him. If anyone has information on this issue.
I would be very grateful.

Andrey Golovatyuk

Tags (4)
3 REPLIES 3
Highlighted

Re: processing Xref in Arbortext IETP Services Version 4.4 M010 (006)

Andrey, could you explain the issue more clearly. I'm not sure I do understand it correctly (I'm pretty sure I don't, actually).

Basically stylesheets used by IETP Viewer are in the \IETPViewer\WEB-INF\xsl\ folder (apart from 'fo' templates used for PDF generation when clicking "Print DM"). And the templates responsible for handling xrefs (including xrefs to hotspots) are in the xref.xsl.

What in particular are you having problems with?

Highlighted

Re: processing Xref in Arbortext IETP Services Version 4.4 M010 (006)

I do not see the links on hotspots in the legend.
That is, should be of the form:
1 Bolt, Figure 1, 1
2 Screw, Fig.1, 2
etc.

And I go
1 Bolt
2 Screw

I know it's all about style xref.xsl
but the system for some reason, it does not react
a feeling that the pattern

<xsl:template match="xref">

does not work. I'm trying to figure out why it does not work
you are using this version 4.4 M010 (006) ?

Highlighted

Re: processing Xref in Arbortext IETP Services Version 4.4 M010 (006)

Sounds like the template isn't matching the way you think it should. Here's a good article about debugging XSLT:

http://publishinggeekly.com/2011/04/25/template-match/

Announcements