cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

I have question about protk.dat file for 3Dconnexion Space mouse Enterprize

dparks-2
1-Newbie

I have question about protk.dat file for 3Dconnexion Space mouse Enterprize

I have done this before many years ago for the use spacepilot where placing the protk.dat file for the utility and menu mapper would startup upon launching Proe,  I just got the new Enterize 3d mouse and cad mouse kit and my issue is that my stratup target is jumping across multiple apllications in order to integrate Enovia with Proe WF5 and this is in itself a protk.dat file.  there are 2 seperate directories of the root of my C drive where on is the stratup for Enovia enviorment variables, paths, and internal standards and following this command set the actual Proengineer directory is accessed and running through config's and protk.dat file for the mouse that redirects to a user folder where the application specifics reside for Proe or other versions of software.  I have placed the protk.dat file in all of these locations renaming the original if necessary or trying to combined the execution commands with in the protk file with the other files but I am not getting the outcome I think I should.  The mouse and 3D mouse are functional but the menu selection that appears at the top of the GUI is not there even though aux. applications shows it is running, plus my Enovia does not launch Either within Proe.

Anyone help.  I can run CMD if needed to diagnose if I knew the right commands to help me with the excencution of the stratup order.  I have been reading the code most of the day and have been successful in getting different things to happen but not everyting the way it is supposed to.  Also should i expect to get mainly test on my LCD screen with no icon associations due to the WF5 and its <relic> status?

any help?

<Thanks All>


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
4 REPLIES 4
DenisJaunin
15-Moonstone
(To:dparks-2)

Hello

Have you loaded the appropriate driver.

Kind regards.

Denis

http://www.3dconnexion.com/service/drivers.html

Dennis,,

Thanks for the response.  Yes I am running 10.4.6 and having success in my other applications.  It is some pathing issue during startup as my IT has Enovia integration in Proe so start target is not in the Pro E installation folder, wish I knew little more about slowing down the startup execution through the cmd.  I have had 3dConnexion launch successfully but ignore the Enovia and vice versa but not both.  I have checked environment vars and tried to couple protk.dat files and placing in different spots but having no success yet.

D

DenisJaunin
15-Moonstone
(To:dparks-2)

MartinHanak
23-Emerald V
(To:dparks-2)

Hi,

two notes follow .

1.] You can start Creo auxiliary application using protkdat config.pro option. If you use this option, you do not have to place protk.dat file into startup directory.

2.] Some auxiliary applications can collide among themselves. The result of application starting can be dependent on startup order.

MH


Martin Hanák
Announcements