cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Your Friends List is a way to easily have access to the community members that you interact with the most! X

ProFeatureStatus - feature status not working well with Rep Simp

MrSteveR_3
12-Amethyst

ProFeatureStatus - feature status not working well with Rep Simp

Hi,

 

When I change the simplified representation, and run an assembly visitor based on ProFeatureTypeGet and ProAsmcompVisibilityGet, I get the right structure (all excluded are not taken). But when it finished, all the inactive feature status refreshes to active. So on the next run,  I get the master simplified representation. I don't know why. Can someone explain me, the reason and how to avoid it?

 

InactiveInactiveNo Rep SimpNo Rep Simp

Thank you!

 

 

 

 

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
RPN
17-Peridot
17-Peridot
(To:MrSteveR_3)

extern ProError ProSimprepActivate (ProSolid p_solid,
ProSimprep *p_simp_rep);

Purpose: Activates the specified simplified representation.


NOTE:

Operates on assemblies only, not parts.
Call ProSolidDisplay() to display simplified rep correctly.


You called ProSolidDisplay()?

 

View solution in original post

2 REPLIES 2
RPN
17-Peridot
17-Peridot
(To:MrSteveR_3)

extern ProError ProSimprepActivate (ProSolid p_solid,
ProSimprep *p_simp_rep);

Purpose: Activates the specified simplified representation.


NOTE:

Operates on assemblies only, not parts.
Call ProSolidDisplay() to display simplified rep correctly.


You called ProSolidDisplay()?

 

MrSteveR_3
12-Amethyst
(To:RPN)

No, I didn't call it.

Thank you! 😊 Adding it, solved the problem.

 

 

Top Tags