cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to connect to thingworx academic stimulator

spatekar
4-Participant

Unable to connect to thingworx academic stimulator

Hello,

I am following the tutorial from IOT university.

In this course, we can connect our thingworx platform with IOT academic stimulator by putting the server, Application key & port. 

I have thingworx running on localhost with apache tomcat. my thingworx server URL is http://localhost:8080/Thingworx/Composer/index.html

but if I placed localhost against server field, I am unable to connect with IOT academic stimulator. I am a newbie here.

My objective is to connect with IOT academic stimulator with localhost URL. Kindly share your input on the same.

Thanks in advance.

10 REPLIES 10

Server URL: academic.cloud.thingworx.com

AppKey: 2998bda1-8fd9-466f-bdd0-2f90d530b97c

Username:

you are not doing it correctly in the server just type-localhost and uncheck the ssl security then it will work for sure on the local machine via apache.keep the port number as 8080

Regards

Deepankar manchanda

@deman I'm having the same problem. I tried to change everything, localhost to port 80/8080 but still cannot connect to the Thingworx server using the simulator. Any other suggestions?

let me give you a snapshot how to do it

jamesso
10-Marble
(To:deman)

What about when using the Java version of the Academic Edge Connector?

 

When I installed my local thingworx instance I decided I would use port 8090 instead.

 

That shouldn't make a difference, right?

jamesso
10-Marble
(To:jamesso)

For the Java Academic edge connector, the port can't be 8090.

 

For my local Windows Server based installation of ThingWorx, once i enabled port forwarding from port 80 to port 8090 on the server, I could use the academic edge connector using port 80 in the configuration panel. Then I could run the Academic edge connector successfully. Perhaps if I had installed my Foundation server to run on port 8080 instead of 8090, then using port 8080 in the edge connector might have worked as well.

This problem still persists. The info provided here by the participants does NOT lead to a solution.

 

I set up a brand new trial edition of the Foundation server. I set it up to use port 8090. I can access the Composer interface through my browser just fine but the same credentials entered into the Academic Edge Connector (app key and thing name) lead to a CONFIG error:

 

[CONFIG]: -> Error malformed URL, check "Server URL" and "Thing Name" Fields. Try adding http:// or https:// to the start of Server URL

 

Is anyone listening still?

 

Jim

jamesso
10-Marble
(To:jamesso)

It seems that the Academic Simulator program does allow port 8090 to be used to connect to a local ThingWorx server as long as the firewall allows inbound connections to port 8090. This is not true of the Academic Edge Connector Java application.

aseaton
5-Regular Member
(To:spatekar)

try using:

 

Server url: 127.0.0.1

AppKey: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx

Port: 80

SSL: unchecked