cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Creo Parametric 4.0 embedded chromium_browser display issue with Windows 10 scale larger than 100%

RandyJones
18-Opal

Creo Parametric 4.0 embedded chromium_browser display issue with Windows 10 scale larger than 100%

The issue is an erractic display in the embedded browser. See below for more detail and some screenshots.

 

This is a 100% reproducible issue as follows:

  • Creo Parametric 4.0 M010-M030
    • haven't tried F000
    • This is not an issue with Creo Parametric 3.0
  • config.pro option windows_browser_type chromium_browser
    • This is not an issue when using ie_browser
  • Windows 10
    • have tried both version 1511 and 1703
    • Windows 7 doesn't have this issue.
  • Windows Scale and Layout set to something larger than 100%
    • common on higher resolution (> 1920 x 1200/1080) monitors to set this larger than 100%
    • 150% is common on a 4k monitor
    • windows_scale.png

With the above setup the embedded browser contains fuzzy content. Looks the same as zoomming greater than 100% on an image in an image viewer. Looks like this:

browser-01.png


Then as soon as you move your mouse inside the browser window and interact with something like a link or icon the content re-scales itself into the upper lh corner of the browser window as shown here. I have highlighted with yellow the new rh edge of the browser window. You can see the previous content to the right of the "new" view.

browser-02.png


I have reproduced this on the following hardware all with Nvidia graphics of various flavors:

  • Dell M6800 laptop
    • Windows 10 1703
    • using only laptop monitor running at 1920x1080 and 125% scale
    • using both laptop monitor and a larger 2nd monitor hooked via display port
  • Gruman
    • Windows 10 1703
    • 2 identical 4k monitors running at 125% scale
  • Sun Ultra 27
    • Windows 10 1511
    • Windows scale at 125%

I have opened a call with PTC but wanted to check to see if anybody else is experiencing this issue or maybe has found a resolution for it.

13 REPLIES 13

Another reason to miss Display Postscript. Also, the potential of SVG.


@dschenken wrote:

Another reason to miss Display Postscript.


Old memories there. Early 1990's running Sun OpenWindows on SPARCStations. SPARCStation 1, SPARCStation 1+, SPARCStation 2, and SPARCStation 10 hardware.

 

I noticed the subject has been truncated turning "100%" into "10".

Subject should be:

Re: Creo Parametric 4.0 embedded chromium_browser display issue with Windows 10 scale larger than 100%

I have a work around for this issue. See PTC article CS265134:

https://www.ptc.com/en/support/article?n=CS265134

 

Using this workaround I have tried the following:

  • disable scaling on Parametric/bin/parametric.exe
    • embedded browser works properly
    • text size as expected in embedded browser
  • disable scaling on Platform/4/zbcefr.exe
    • embedded browser works properly
    • text size is small in embedded browser
  • disable scaling on Agent/creoagent.exe
    • embedded browser works properly
    • text size as expected in embedded browser
GiacomoP
4-Participant
(To:RandyJones)

Hi, we have the same problem.

Windchill Chromium embedded browser has lot of graphic glitch using Windows 10 Scaling with a 4K resolution.

 

This workaround solves graphic glitches but the Windchill embedded browser shows very small characters because use the default 100% scaling.

With such small characters it is impossible to use the application.

(We encountered whis problem with different NVIDIA Quadro graphics cards and with different Workstations)

I have been having similar issues with Creo 8

 

In Creo 6 the embedded browser works great, but in the Creo 8 testing instance it looks normal on my laptop screen (set to 1080p and 125% scaling), but as soon as I move it to my ultrawide with 100% scaling the browser looks like yours

 

I found the workaround to have my config file set to high_dpi_enabled no

but now my embedded browser is too large for my taste and side by side with firefox, the windchill instance in my embedded browser looks like its set to the 125% scaling of my laptops built in screen. So frustrating!

 

How is htis a problem now on Creo 8 but wasnt on Creo 6!

Chris3
19-Tanzanite
(To:JavierL)

They changed the default zoom setting starting with Creo 7. Vote up the idea below:

https://community.ptc.com/t5/Creo-Parametric-Ideas/Chromium-zoom-settings-for-windchill-in-creo-para... 

JavierL
7-Bedrock
(To:Chris3)

Voted, thanks!

llie
14-Alexandrite
(To:JavierL)

We have experienced this with HP ZBook laptops with High Definition (4K) screen. Below are the steps to fix your issues.

Solution/Workaround:

1.Set Windows default browser to Chrome

2.From Creo set the config.pro option, windows_browser_type to “chromium_browser

3.Navigate to Creo loadpoint. ex: C:\Program Files\PTC\Creo 5.0.5.0\Parametric\bin, right click on “Parametric.exe”, Properties

4.From the Properties Compatibility tab, select Change high DPI settings

5.Check the box Override High DPI scaling behavior and set to “System

 

We have ModelCheck and PDM window random behavior and this fixed it.

 

llie
14-Alexandrite
(To:RandyJones)

We have experienced this with HP ZBook laptops with High Definition (4K) screen. Below are the steps to fix your issues.

Solution/Workaround:

1.Set Windows default browser to Chrome

2.From Creo set the config.pro option, windows_browser_type to “chromium_browser

3.Navigate to Creo loadpoint. ex: C:\Program Files\PTC\Creo 5.0.5.0\Parametric\bin, right click on “Parametric.exe”, Properties

4.From the Properties Compatibility tab, select Change high DPI settings

5.Check the box Override High DPI scaling behavior and set to “System

 

We have ModelCheck and PDM window random behavior and this fixed it.

 

Mat
12-Amethyst
12-Amethyst
(To:llie)

Thanks for Your Tipp.

But unfortunately my Creo Installation ( 8.0.3.0) acts weird.

dpi_scale 150

dpi-settings of parametric.exe to "system"

 

Mat_1-1645456553282.png

Please note the shifted content of the browser window!

 

When I deactivate dpi_scale, I get this (more or less the same)

Mat_2-1645456821914.png

 

 

When I set "dpi_scale 100", I get pretty much the same result as if I would not set it at al (with High DPI scaling to "system" in the background).

 

These are the results with HIGH DPI scaling set to "Application" for parametric.exe

dpi_scale 100

Mat_3-1645457266633.png

works, but I have to use binoculars to read the text.

dpi_scale 150

Mat_4-1645457472354.png

 

work way better, but You have to adjust the browser's content to a not-clunky-state using "ctrl" + "-".

But after a restart (or changing to a different web-site) Your are back in clunky-town.

So please support this:

https://community.ptc.com/t5/Creo-Parametric-Ideas/Chromium-zoom-settings-for-windchill-in-creo-para...

and to PTC:

Please buy Your developers and testers some modern monitors. It is time to get those CRTs recycled.

 

Mat
12-Amethyst
12-Amethyst
(To:Mat)

Seems, that I found a solution for the issues with my Creo 8's embedded browser.

(Creo 8.0.4.0 / Windows 10 / embedded chromium browser)

 

I solved this issue with NOT setting any compatibility settings for parametric.exe.

Instead I set the compability setting for "zbcefr.exe" in "C:\Program Files\PTC\Creo\Platform\8\" to "Application"

Mat_0-1650977274592.png

Seems to work so far.

 

We ran into the same issue.

Our easiest workaround to fix this is setting the config.pro setting dpi_scale to a value of 100.

In my case the best result was to use Application as override setting. (Creo 4.0 M070)

And adding shade_quality 8 to the config also gets an better 3D view

 

ptc5132323_0-1655464456660.png

 

Announcements