cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Losing changes

BenLoosli
22-Sapphire III

Losing changes

We turned ModelCheck on back in July. Since then a couple of the designers have reported that when the reopen an assembly the next day or later, the changes they saved have not been saved. I turned it off for the past 10 days and one user reported no issues with ModelCheck turned off. We are not preventing check-in to WIndchill for errors, everything that would be an error is right now only being flagged as a warning.

We do know that ModelCheck slows down the check-in process. I had to block 4 files from running ModelCheck as it was taking over an hour to process the drawing on check-in.

I have cautioned the users to watch the rolling arrows at the bottom of the screen and not close their part or Creo while the arrows are rolling. 

Is there anything else to set or check in ModelCheck, Creo or Windchill that will prevent lost work?

We are on WIndchill 11.0 M030 CPS16 with Creo 4 M080.

I can move to M150 if that might help. I am working on a total upgrade to Windchill 11.1 M020 and Creo 7 or 8.

6 REPLIES 6
Chris3
19-Tanzanite
(To:BenLoosli)

I am certainly not a modelcheck expert. We just rolled it out this year and we are in a similar position as you.

 

They way that we have it setup, it checks parameters and changes them automatically without any prompt from the user if they are wrong or missing. Doing this causes the parts to be modified in session without checking them out. Is it possible this is happening for your users and they are making the changes to the equivalent of hitting "continue" and then they don't get checked in?

 

We are on Creo 7

@BenLoosli Not that it changes my response, but I'm guessing you're using Interactive Mode? Creo 6 has an enhancement that may help:

  • Creo 5: Modernized ModelCheck Report
    • PTC added a hidden config.pro option to Creo 4 (not sure which version) to turn on the new Creo 5 MC UI - modelcheck_show_new_report_ui yes
    • If you use the new UI, I really like showing ALL errors/warnings using the hidden config_init.mc. Related product idea to unhide this setting and default it to yes. 
      MC_REPORT_SHOW_ALL_TAB YN Y Y Y Y
  • Creo 6: Reports Are Improved in Creo ModelCHECK - They added a reminder to save changes after using the ModelCheck GUI to make changes. Unfortunately, I don't believe this made it back to Creo 4.

@Chris3 Here's a product idea I created to Align Creo ModelCheck with Windchill Gatekeeper. In the condition.mcc file, you could reduce checking released files by setting a condition like IF (PTC_WM_LIFECYCLE_STATE EQ RELEASED) NOCHECK but there's currently no option to check the Windchill

workspace status for NEW, LOCALLY_MODIFIED, or CHECKED_OUT. Another idea could be to use ModelCheck in Save mode - one reason being to reduce ModelCheck from modifying lots of files (especially in a Windchill environment). MC Save only checks the file you're saving. Save mode would not have the ModelUpdate capabilities to automatically change/fix models but you could always launch MC Interactive manually when needed. I haven't really tried these but some here's some config_init.mc to consider:

BenLoosli
22-Sapphire III
(To:BenLoosli)

@lhoogeveen 

We are using ModelCheck to automatically do the checking at Save. I think this may be where some users are not waiting for it all to complete before closing their file or closing Creo. I have seen some ModelCheck reports where the status buttons are not fully populated in the report file. There will 2 or 3 status buttons shown but not all 4 and the data is not in the file.

Glad to hear that the reports have been updated.

I am working on the upgrade to Windchill 11.1 M020 and Creo 7/8.

@BenLoosli There is a config_init.mc call SAVE_MC_PRE for Save mode that controls whether ModelCheck runs before or after saving that maybe relevant as well.

BenLoosli
22-Sapphire III
(To:lhoogeveen)

@lhoogeveen It is already set: SAVE_MC_PRE      YN      Y

lwestbrook
15-Moonstone
(To:BenLoosli)

Hi Ben,

 

I wonder if you should try setting that config to N instead? That way, the save operation happens before ModelCHECK actually runs. If your users are pressing save but not waiting for ModelCHECK to completely run before exiting, that could be what's causing the work to be lost.

 

Luke

Announcements