cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Moduleworks : Cutcom still not working

RaphMORIN
13-Aquamarine

Moduleworks : Cutcom still not working

I'm really getting annoyed about this Moduleworks. I loaded this morning Creo 3.0 M110 full of hope about this new release.

I started programming a new part and simulated,cutcom is still not correctly simulated !!!   What's going on ? A simulating tool is to make sure everything goes well, not supposed to give doubts about what we are doing. I'm once more going to go back to M080 which works with Vericut perfectly.

I'm going to open a new case about this "new" problem !!

I can't see the benefits of paying a maintenance to get such a result. In our company, we're seriously thinking about changing cam software for many reasons. And these problem are just confirming what we are thinking.

And when will Pro/NC will be a standalone module ? Our company is well developing and we're getting more and more job. We are thinking of hiring a new employee, to have one on

CAD and the other one on CAM. But actually with Creo it's really a big problem !!! Who can think of paying a CAD licence to do CAM job ? Serisously !!

12 REPLIES 12
SteveLucas
13-Aquamarine
(To:RaphMORIN)

Sorry you are still having problems with Module works. They fixed my problem where my ball end mills looked like chamfer tools with M110 but now I discovered a new problem with it. Some imported tool assemblies don't show up in Moduleworks. Not sure why I am still investigating it.

Play path image

play_path_module_wrks_no_tool.JPG

Module works image

module works tool noshow.JPG

The biggest problem I have with module works is it is slow to show the cuts. I have all the settings in ModuleWorks set to the lowest quality and it still takes forever.

Not sure if it's my work which is small and very fine detail or if it's my computer. Personally I think it's ModuleWorks.

RaphMORIN
13-Aquamarine
(To:SteveLucas)

I agree with you. Moduleworks is slow. I recently changed computer and hoped to get better results but it didn't change much. Here's what I have :

And a Nvidia QUADRO K2200.

RaphMORIN
13-Aquamarine
(To:SteveLucas)

I'm seriously thinking of stopping maintenance on the CAM package. But unfortunately I don't think it's possible to stop on CAM and continue on CAD. We have to stop for everything I think.

Hi,

I hope your VAR can answer your question whether it's possible to stop on CAM and continue on CAD.

MH


Martin Hanák
RaphMORIN
13-Aquamarine
(To:MartinHanak)

In fact I called him this morning. He told me that often when a customer does this, after you can't use anymore CAM at all. He told me it depends on what PTC decides. So I asked him to see with PTC to have a true answer ! And not it depends...

I would be really upset about this as we bought the cam package and we're supposed to use it as long as we want.

I suppose the issue is if you stay on maintenance for CAD and upgrade to Creo Parametric 4.0, but your CAM license is only good for Creo 3.0 you will no longer be able to open the Creo 4.0 files in CAM.  I suppose you could import STEP files into CAM and continue to use it, but that would be more painful than maintenance.

RaphMORIN
13-Aquamarine
(To:RaphMORIN)

And another release and still the same problems !!

We're now about to change cam software...

post processor.PNG

try to modify the post processor and then you will be able to use cutter compensation correctely (image added above for your reference)

Thank you for this answer, but the problem comes from Moduleworks. Moduleworks simulates the CL data and not the ISO code.

We have milled hundreds of parts using this program and it works perfectly fine unlike Moduleworks.

SteveLucas
13-Aquamarine
(To:RaphMORIN)

I doubt you will see PTC get into the game of checking the iso code after post processing because once the NCL file is posted PTC has lost control of it and that will open up a whole new set of headaches and problems for them.

That is why I switched to NCsimul because it checks the posted code and allows modification of the posted file rather than the NCL like module works. I am sure Vericut does the same. I still use Module works while programming for quick checks but when I think the program is ready to go to the floor I run NCsimul

RaphMORIN
13-Aquamarine
(To:RaphMORIN)

Creo 4.0 M010, cutcom still not gettine correctly simulated in Moduleworks ! Will it get fixed one day ???

Announcements