cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to get Engineer III license but able to get Essentials II license

jsawyer-2
6-Contributor

Unable to get Engineer III license but able to get Essentials II license

I am standing up a new license server and after beating it in to submission so that it runs stably I am now encountering something that I do not understand.

 

I am able to connect a session to the server and get a Creo Essentials II license but when I try to request an Engineer III license I get an "unable to connect to the license server" error. It is not a no licenses available error but a can't connect error. There are licenses available and if I drop back to just the II license it grabs one just fine.

 

#################### FLOATING License ####################
# Serviceable = Creo Engineer III
# Feature Name = PROE_EngineerIII
# Feature Version = 37.0
# Number of Copies = 1
# Expiration Date = permanent

 

#################### FLOATING License ####################
# Serviceable = Creo Essentials Team
# Feature Name = PROE_EssentialsII
# Feature Version = 37.0
# Number of Copies = 4
# Expiration Date = permanent

 

Again, this is a new server. There are no clients attached to it other than the one I am testing with.

12 REPLIES 12
VladimirN
23-Emerald V
(To:jsawyer-2)

jsawyer-2
6-Contributor
(To:VladimirN)

Sadly opening a support case is mostly useless. I have opened one and I expect the usual routine. One of their "support engineers" will call me at 5:30 in the morning my time because they do not bother to look at where the customer is located and when I try to respond to them they will not be available or will ask me to send them a bunch of log files and other information to send to "the dev team". A few days later they will again call me at 5:30 AM and leave me a voice mail telling me that they have not found an issue.

Hi,

1.] check ptcstatus.bat output on client

2.] check contents of ENV=PTC_D_LICENSE_FILE-= line in both psf files (if you upload them i can check them)


Martin Hanák
jsawyer-2
6-Contributor
(To:MartinHanak)

The client is able to see the license server without any issues.

 

Displaying status for license file: 7788@192.168.10.31
License Server is UP: 7788@192.168.10.31

Warning (-96): Cannot connect to license server.

License In Use Free
------- ------ ----
Advanced_Assembly_SET* Counted
PROE_EssentialsII Uncounted, Locked
PROE_EssentialsII Counted
Mecui_Advanced Counted
Meceng_Advanced Counted
PROE_EngineerIII Counted
MECBASICENG_License Counted
MECBASICUI_License Counted
CREOSCHEM_Lite Counted

* = License Extensions - Available only on startup.
^ = Borrowed License.

 

The .psf file looks fine.

ENV=ZIP_EXEC=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\zip.exe
ENV=CLHOME=%PRO_DIRECTORY%\text\pcldata
ENV=PVIEW_PROEPVIEW_HOME=%PRO_DIRECTORY%\apps\prodview
ENV=CV_ENV_HOME=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\CV140
ENV=DEBUG_HLP_DLL_PATH=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\lib\dbghelp.dll
ENV=PTC_D_LICENSE_FILE-=7788@192.168.10.31
ENV=CREO_APP=PMA
ENV=CREOPMA_FEATURE_NAME=PROE_EngineerIII (10119)
RUN="%MECH_LP%\install\nt\pro_mech_env.bat"
RUN="%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\nms\nmsd.exe" -noservice -timeout %NMSD_TIMEOUT% &
RUN="%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\xtop.exe"
ENV=DBG_NCPOST_PATH=%CREOAPP_DIRECTORY%\bin
ENV=PRO_ALLOW_EARLY_RETURN=TRUE
// USER - PSF
// Add User specific environment or run applications below here

ENV=PTC_SUPPRESS_LMLIC_ENV=no

 

I can ask it to pull only a Creo Essentials license and it has no issues. I ask for the Engineer III and it can't.

BenLoosli
22-Sapphire III
(To:jsawyer-2)

Is this one license file for both Essentials II and Engineer III or separate files?

If separate files, how are you switching between them?

Are you launching from parametric.bat or directly against parametric.exe?

 

jsawyer-2
6-Contributor
(To:BenLoosli)

It is a single license file on the license server. The file shows both as available. I am launching from the Creo Parametric desktop short cut that is created when you install Creo. If I configure Creo Parametric to ask for a Creo Essentials license it works just fine. Changing nothing other than re-configuring to request an Engineer III license I get a "server is not available" error on start up.

BenLoosli
22-Sapphire III
(To:jsawyer-2)

Try launching the parametric.exe file from the install location.

If both licenses are configured, it should give you a pop-up asking which license you want to use.

 

jsawyer-2
6-Contributor
(To:BenLoosli)

It does not ask me which license I want to use it just grabs the Essential II and will not pull AAX with it.

License_Configuration.JPG

Licenses_Obtained.JPG

jsawyer-2
6-Contributor
(To:jsawyer-2)

To close the loop on this, it is an issue with the Creo and the error message that it throws. I was not clearing the AAX request and when Creo 4.0 M110 tried to bull both an Engineer III license and an AAX license it became confused. Instead of presenting a "license unavailable" message it instead throws a "Server unavailable" error and shuts down.

 

Requesting just an Engineer III license and removing the AAX request and it is happy.

TomU
23-Emerald III
(To:jsawyer-2)

If you didn't create a case, it might be worth it so this can be reported.


@jsawyer-2 wrote:

The client is able to see the license server without any issues.

 

Displaying status for license file: 7788@192.168.10.31
License Server is UP: 7788@192.168.10.31

Warning (-96): Cannot connect to license server.

License In Use Free
------- ------ ----
Advanced_Assembly_SET* Counted
PROE_EssentialsII Uncounted, Locked
PROE_EssentialsII Counted
Mecui_Advanced Counted
Meceng_Advanced Counted
PROE_EngineerIII Counted
MECBASICENG_License Counted
MECBASICUI_License Counted
CREOSCHEM_Lite Counted

* = License Extensions - Available only on startup.
^ = Borrowed License.

 

The .psf file looks fine.

ENV=ZIP_EXEC=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\zip.exe
ENV=CLHOME=%PRO_DIRECTORY%\text\pcldata
ENV=PVIEW_PROEPVIEW_HOME=%PRO_DIRECTORY%\apps\prodview
ENV=CV_ENV_HOME=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\CV140
ENV=DEBUG_HLP_DLL_PATH=%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\lib\dbghelp.dll
ENV=PTC_D_LICENSE_FILE-=7788@192.168.10.31
ENV=CREO_APP=PMA
ENV=CREOPMA_FEATURE_NAME=PROE_EngineerIII (10119)
RUN="%MECH_LP%\install\nt\pro_mech_env.bat"
RUN="%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\nms\nmsd.exe" -noservice -timeout %NMSD_TIMEOUT% &
RUN="%PRO_DIRECTORY%\%PRO_MACHINE_TYPE%\obj\xtop.exe"
ENV=DBG_NCPOST_PATH=%CREOAPP_DIRECTORY%\bin
ENV=PRO_ALLOW_EARLY_RETURN=TRUE
// USER - PSF
// Add User specific environment or run applications below here

ENV=PTC_SUPPRESS_LMLIC_ENV=no

 

I can ask it to pull only a Creo Essentials license and it has no issues. I ask for the Engineer III and it can't.


Hi,

 

following ptcstatus.bat output is incorrect.

 

Displaying status for license file: 7788@192.168.10.31
License Server is UP: 7788@192.168.10.31

Warning (-96): Cannot connect to license server.

License In Use Free
------- ------ ----
Advanced_Assembly_SET* Counted
PROE_EssentialsII Uncounted, Locked
PROE_EssentialsII Counted
Mecui_Advanced Counted
Meceng_Advanced Counted
PROE_EngineerIII Counted
MECBASICENG_License Counted
MECBASICUI_License Counted
CREOSCHEM_Lite Counted

* = License Extensions - Available only on startup.
^ = Borrowed License.

 

Warning (-96): Cannot connect to license server. error message usually means that firewall running on license server is blocking "license communication" between server and client.

To check this idea, simply disable firewall on server temporarily.

---

Also SERVER line in license.dat file in FLEXnet_loadpoint\licensing directory must contain IP address 192.168.10.31 (if it contains server name replace it with IP address and restart licensing service ... I hope it is lmadmin_ptc).

---

If firewall must run on server then define incoming rules enabling communication for lmadmin.exe and ptc_d.exe executables (you can find them in FLEXnet_loadpoint\x86e_win64\obj directory).

 


Martin Hanák

Note:

To see correct ptcstatus.bat output, run it on license server from FLEXnet_loadpoint\bin directory.


Martin Hanák
Announcements