cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Help us improve the PTC Community by taking this short Community Survey! X

user format directory

BenLoosli
23-Emerald II

user format directory

When I open Creo with Windchill, and go to replace a format in Sheet Setup, I have a User Format folder listed and that is what is open to select my new format.

When another user does it, he is in the System formats folder and no option on the left for user formats.

 

I am an admin of Windchill, and the other user is not.

We have pro_format_dir set in a system wide config.pro to look in Windchill for the formats.

 

Any suggestions as to why a normal user cannot see these formats?

 

Windchill 11.0 m030 CPS06

Creo 2.0 m240

1 ACCEPTED SOLUTION

Accepted Solutions
BenLoosli
23-Emerald II
(To:BenLoosli)

I found the issue.

Since I was logging into the other accounts from my workstation, they had PDM registered for Windchill, but when I checked on their workstations, it was set to the server name. Fixed it on the user's workstations and everything is fine now. Not sure why I had PDM for their accounts but still could not see User Formats.

 

View solution in original post

6 REPLIES 6
rreifsnyder
13-Aquamarine
(To:BenLoosli)

First double check that the user can at least view the container you have your formats in. Second thing that I have run across is that the name they have in Server Management is not the same as your system wide one. If they haven't matched exactly then the path that's actually used in the config option won't find the formats.

BenLoosli
23-Emerald II
(To:rreifsnyder)

I tried two different users and my account. All 3 accounts have Windchill set as PDM in Server Registry.

System config.pro is pointing pro_format_dir to wtpub://PDM/Libraries/CFG_Lib/Main/PTC_settings/formats.

I can navigate to that folder and open the formats directly into Creo on both users.

Both of them are in the same roles and groups within Windchill.

 

Community Admin Edit:

 

 

RichardKoneth  2-08-2019  5:25AM

 

Get out the config.pro setting for pro_format_dir and copy this path to an open dialog box in Creo - does it work or do you get an error?

One know problem is, the name of Windchill system ist case sensitive for many of such config settings referencing to Windchill folders...

 

BenLoosli  2-8-2019  8:54 AM

I found the issue.

Since I was logging into the other accounts from my workstation, they had PDM registered for Windchill, but when I checked on their workstations, it was set to the server name. Fixed it on the user's workstations and everything is fine now. Not sure why I had PDM for their accounts but still could not see User Formats.

rreifsnyder
13-Aquamarine
(To:BenLoosli)

I guess I'd verify that they don't have competing config.pro files that might be directing those users to other places. Maybe old versions of the system config.pro?

TomU
23-Emerald IV
(To:BenLoosli)


@BenLoosli wrote:

All 3 accounts have Windchill set as PDM in Server Registry.

System config.pro is pointing pro_format_dir to wtpub://PDM/Libraries/CFG_Lib/Main/PTC_settings/formats.

I can navigate to that folder and open the formats directly into Creo on both users.

Both of them are in the same roles and groups within Windchill.

 


The server name needs to match what's being used in your config path.  Based on the path you show, they need to have their server named "PDM", not "Windchill".

 

 

TomU
23-Emerald IV
(To:TomU)

Forget that.  I misread your response.  Sounds like you have it right.  Double check your running config and make sure the path isn't being changed.  Make sure you restart Creo if you make changes to this.  It's only read during startup.

BenLoosli
23-Emerald II
(To:BenLoosli)

I found the issue.

Since I was logging into the other accounts from my workstation, they had PDM registered for Windchill, but when I checked on their workstations, it was set to the server name. Fixed it on the user's workstations and everything is fine now. Not sure why I had PDM for their accounts but still could not see User Formats.

 

Announcements
NEW Creo+ Topics: PTC Control Center and Creo+ Portal