cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Error occurred: at startup

SOLVED
Highlighted
Visitor

Error occurred: at startup

Hi,

 

I had a BlueScreenOfDeath while working on in Vuforia Studio.  Since then, Vuforia Studio would not start.  I have rebooted, repaired and uninstalled/rebooted/reinstalled - and still have the same problem. Can someone review the logs and suggest my next steps ?

Thanks

 

[2019-05-16T06:09:04.963Z] Studio 8.4.3.4381
[2019-05-16T06:09:05.080Z] Status Message: Removing previous files...
[2019-05-16T06:09:05.080Z] Removing C:\Users\msmith24\AppData\Roaming\VuforiaStudio\studio-download.vuforia.io\dist
[2019-05-16T06:09:05.538Z] Unzipping mbdist.zip to C:\Users\msmith24\AppData\Roaming\VuforiaStudio\studio-download.vuforia.io\
[2019-05-16T06:09:05.547Z] Status Message: Performing setup (Application)...0%
[2019-05-16T06:09:05.556Z] Status Message: Performing setup (Application)...1%
[2019-05-16T06:09:05.566Z] Status Message: Performing setup (Application)...2%
...
[2019-05-16T06:09:06.678Z] Status Message: Performing setup (Application)...98%
[2019-05-16T06:09:06.686Z] Status Message: Performing setup (Application)...99%
[2019-05-16T06:09:06.699Z] Status Message: Removing previous files...
[2019-05-16T06:09:06.699Z] Removing C:\Users\msmith24\AppData\Roaming\VuforiaStudio\studio-download.vuforia.io\node_modules
[2019-05-16T06:09:28.894Z] The directory is not empty.

[2019-05-16T06:09:28.894Z] Unzipping mbmodules.zip to C:\Users\msmith24\AppData\Roaming\VuforiaStudio\studio-download.vuforia.io\
[2019-05-16T06:09:29.078Z] Status Message: Performing setup (Libraries)...0%
[2019-05-16T06:09:29.386Z] Status Message: Performing setup (Libraries)...1%
[2019-05-16T06:09:29.730Z] Status Message: Performing setup (Libraries)...2%
...
[2019-05-16T06:10:18.587Z] Status Message: Performing setup (Libraries)...98%
[2019-05-16T06:10:19.040Z] Status Message: Performing setup (Libraries)...99%
[2019-05-16T06:10:19.625Z] Status Message: Getting ready...
[2019-05-16T06:10:19.625Z] Starting node.exe
[2019-05-16T06:10:23.952Z] info: [twx-studio:index] Studio Version 8.4.3.4381
[2019-05-16T06:10:24.143Z] info: [twx-studio:initializer] Node version: 10.15.3
[2019-05-16T06:10:24.143Z] info: [twx-studio:initializer] studio launched with the following arguments: { _: [ 'C:\\Users\\msmith24\\Documents' ],
'$0':
'..\\..\\..\\..\\..\\..\\Roaming\\VuforiaStudio\\studio-download.vuforia.io\\dist\\server\\index.js' }
[2019-05-16T06:10:24.145Z] info: [twx-studio:initializer] studio dir: C:\Users\msmith24\Documents\VuforiaStudio , home dir: C:\Users\msmith24\Documents
[2019-05-16T06:10:24.154Z] error: [twx-studio:builderSettingService] Could not open the builder settings file: SyntaxError: Unexpected token in JSON at position 0
at JSON.parse (<anonymous>)
at Object.initialize (C:\Users\msmith24\AppData\Roaming\VuforiaStudio\studio-download.vuforia.io\dist\server\services\builderSettingService.js:74:29)
at C:\Users\msmith24\AppData\Roaming\VuforiaStudio\studio-download.vuforia.io\dist\server\services\initializer.js:107:31
at new Promise (<anonymous>)
at _initializeStudioDirs (C:\Users\msmith24\AppData\Roaming\VuforiaStudio\studio-download.vuforia.io\dist\server\services\initializer.js:74:12)
at Object.init (C:\Users\msmith24\AppData\Roaming\VuforiaStudio\studio-download.vuforia.io\dist\server\services\initializer.js:63:12)
at Object.<anonymous> (C:\Users\msmith24\AppData\Roaming\VuforiaStudio\studio-download.vuforia.io\dist\server\index.js:23:38)
at Module._compile (internal/modules/cjs/loader.js:701:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:712:10)
at Module.load (internal/modules/cjs/loader.js:600:32) SyntaxError: Unexpected token in JSON at position 0
at JSON.parse (<anonymous>)
at Object.initialize (C:\Users\msmith24\AppData\Roaming\VuforiaStudio\studio-download.vuforia.io\dist\server\services\builderSettingService.js:74:29)
at C:\Users\msmith24\AppData\Roaming\VuforiaStudio\studio-download.vuforia.io\dist\server\services\initializer.js:107:31
at new Promise (<anonymous>)
at _initializeStudioDirs (C:\Users\msmith24\AppData\Roaming\VuforiaStudio\studio-download.vuforia.io\dist\server\services\initializer.js:74:12)
at Object.init (C:\Users\msmith24\AppData\Roaming\VuforiaStudio\studio-download.vuforia.io\dist\server\services\initializer.js:63:12)
at Object.<anonymous> (C:\Users\msmith24\AppData\Roaming\VuforiaStudio\studio-download.vuforia.io\dist\server\index.js:23:38)
at Module._compile (internal/modules/cjs/loader.js:701:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:712:10)
at Module.load (internal/modules/cjs/loader.js:600:32)
[2019-05-16T06:10:24.154Z] error: [twx-studio:builderSettingService] original contents:

[2019-05-16T06:10:24.154Z] error: [twx-studio:builderSettingService] Error occured around:

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Error occurred: at startup

Hi @MikeDSmith2,

Please take a backup of builder-settings.json file (located at C:\Users\<username>\Documents\VuforiaStudio) and delete it from the folder C:\Users\<username>\Documents\VuforiaStudio. Close all the Studio applications and stop the service by clicking on 'Exit':

Screenshot_7.png

 

Restart the Studio application. Hope this helps to resolve the issue!

View solution in original post

1 REPLY 1

Re: Error occurred: at startup

Hi @MikeDSmith2,

Please take a backup of builder-settings.json file (located at C:\Users\<username>\Documents\VuforiaStudio) and delete it from the folder C:\Users\<username>\Documents\VuforiaStudio. Close all the Studio applications and stop the service by clicking on 'Exit':

Screenshot_7.png

 

Restart the Studio application. Hope this helps to resolve the issue!

View solution in original post

Announcements
Topics available:
AR/VR for Data Optimization AR/VR for Security and Control AR/VR for Inspection