cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Windchill 10.1 and Office 2013

ptc-3452758
1-Newbie

Windchill 10.1 and Office 2013

Will M050 add support of office 2013? We will be upgrading office long before we upgrade to 10.2.

Thanks,

Wayne

16 REPLIES 16

Per the Windchill Planned Future Support document (http://www.ptc.com/WCMS/files/69784/en/PTCWindchillFuturePlatformSupportSummary3414.pdf) Office 2013 is not planned to be supported with 10.1

Thanks Lori, I have seen that document. I was hoping PTC would add support in future datecode releases for 10.1. It appears to already work with Office 2013 and as I think most of us know Office is updated much more often than Windchill. If PTC expects us to use Windchill for a document control tool they need to do a better job of incorporating newer versions into currently supported platforms. Many people stay on Windchill for many years while Office could update much more frequently.

Wayne

DarrenStorey
5-Regular Member
(To:ptc-3452758)

As Lori states, DTI for Office 2013 is not supported with 10.1, however we do seem to be able to use it without issues so far with 10.1 M040. How much longer I will be saying that remains to be seen.

As Microsoft pedal their O365 licence in the cloud model, it means more and more people will be constantly using the very latest version of Office. If PTC continue to be months and years behind in terms of DTI support this potentially poses a problem. I would be interested to hear PTC's view on this issue.

Wayne, Darren,

I've forwarded this concern over to product management, and I'll keep you posted on what I find out.

sm
1-Newbie
1-Newbie
(To:LoriSood)

Hi,

PTC is currently in the process of evaluating whether or not support for Microsoft Office 2013 can be enabled at Windchill 10.1_M050. I'm assuming this request is regarding Windchill Desktop Integration since the browser interface has no specific dependencies on the version of Office being used. I will post an update as soon as more information is availble.

-Scott Morris

Windchill Document Management Group

ptc-3452758
1-Newbie
(To:sm)

This is great news. And you did a very good presentation at PTCLive.

sm
1-Newbie
1-Newbie
(To:ptc-3452758)

Thanks. I thought a software demo would be a little more exciting than an hour of slides for this session

I have just confirmed with PTC QA that Microsoft Office 2013 is included in the Windchill 10.1_M050 validation matrix. Assuming there are no show-stoppers, PTC will be providing support for Micorosft Office 2013 in Windchill 10.1_M050.

I have submitted a request to have the 10.1_M050 Software Matrices and the Future Platform Support documents updated to reflect this change. Hopefully it will be live in a week or two.

Scott,

What about visualisation of Office 2013 docs in Windchill 10.1 - ie PDF publishing?

Will the publishing system be able to run the Office 2013 PDF conversion with Adobe Live Cycle and the Creo View Adapters - I suspect that there might be an issue with this.

We are currently still having to run Office 2010 on our Publishing worker for this reason. It seems to do an OK job of publishing 2013 docs that users upload to Windchill, but I would like to be able to run Office 2013 on the PDF worker if possible.

Interested to hear your thoughts on this...

Rgds

Gary

Hi Gary,

I think PTC can't officially support publishing office 2013 until Adobe LiveCycle supports it.

http://helpx.adobe.com/livecycle/help/livecycle-es4-supported-platforms.html#Software

I'm curious - did you ever run into this error while publishing office 2013 on your PDF worker CS165052 ? We're slated to go to Office 2013 soon and also start using PDF publishing so I'm wondering what you've experienced. I know you said it was "OK", but I'm just wondering how bad the hiccups were :-). I could delay the office 2013 rollout if it's too bad.

thanks

adam

Hi,

Yes, that is exactly the error that I got, it is because Adobe Livecycle ES3 does not recognise the Office 2013 versioned documents.

We have retained Office 2010 on the worker and have upgraded most of our Windchill users to Office 2013 now with no reported issues.

My understanding is that Office 2010 will open 2013 files OK for reading so presumably this will allow them to publish using 2010 and Livecycle ES3 - it seems to work.

We are running Windchill 10.1 M040 & Creo View Adapters 3.0 M010.

Hope that helps.

Rgds

Gary

sm
1-Newbie
1-Newbie
(To:GaryMansell)

Okay, the Office 2013 support at 10.1 M050 is official. TBH, I would not expect many issues at 10.1 M040.

https://support.ptc.com/appserver/cs/view/solution.jsp?source=subscription&n=CS139353

I am looking into the WVS request now. My understanding is the same as Gary's. Office 2010 should be able to open Office 2013 documents without any issues, so the publishing can stay at 2010. WVS is not my specialty, so I'll report back if there's any perceived issues.

Scott,

That sounds promising - what version of Adobe LiveCycle is needed for this to work and is it available on the PTC download site?

I quite fancy trying it with my 10.1 M040 System and Creo 3.0 M010 Worker config...

Rgds

Gary

Gary,

Information regarding LC Server support with the Adapter for PDF can be found here:

3.0 M020

http://support.ptc.com/WCMS/files/160178/en/CVAdapters3.0M020_21July14.pdf

3.0 M010:

http://support.ptc.com/WCMS/files/157399/en/CVAdapters3.0M010_23May14.pdf

You may use ES3 if using 3.0 M010.

Assuming you have the licenses for it the Adobe LC ES3/ES4 images are available on the download site under the CV Adapters downloads:

https://support.ptc.com/appserver/auth/it/esd/product.jsp?prodFamily=WNP

Lori,

The PTC support matrix only makes mention of LiveCycle ES3/4 supporting Office 2010 and no mention of Office 2013, which is what this discussion is all about...So how can Office 2013 support be "official" at 10.1 M050 if Adobe LiveCycle ES 3/4 does not support it - does 10.1 M050 support a later release of Adobe Live Cycle than ES3/4?

Also, the PTC download link that you pointed me to still only shows ES2 - I had to make a request to Tech Support to get hold of ES3 - is this the same for later versions?

Rgds

Gary

Gary,

Unfortunately, the Adapters cannot fully support MS Office 2013 until Adobe supports it. As of ES4 SP1 this is not the case:

http://helpx.adobe.com/livecycle/help/livecycle-es4-supported-platforms.html#Software

PTC's support of Office 2013 will have to extend to just the use of DTI until that happens. For now, Office 2010 will have to be used to publish the documents to PDF. As long as the 2013 documents can be retrieved in 2010 then I don't believe that this should be a problem.

The ES3 download is available under the Creo View 2.0 adapters and the ES4 is available under the Creo View 3.0 adapters:

7-31-2014+6-50-27+PM.png

Hi Lori,

I understand now - I was hoping that when you said PTC "officially" supported Office 2013, that there was a new release of Adobe LiveCycle that came with 10.1 M050 and the related CV Adpaters that I could download and use with my 10.1 M040 System 😞

Also perhaps you can point me in the right direction to get my Creo View Download page sorted so that it shows the ES3 and ES4 downloads - I only get the ES2 download under Creo 1, and not the others that you show (although our maintenance is fully paid up)?

CV-Downloads.JPG

Thanks and Regards

Gary

Announcements