cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Need to share some code when posting a question or reply? Make sure to use the "Insert code sample" menu option. Learn more! X

Explosion View - Images were skipped

Model_1975
8-Gravel

Explosion View - Images were skipped

Hello Community,

 

I just wanted to make another project and tried to make a smooth explosion transition (from normal view to explosion view). In the first step I only need a transition in creo - not a separate movie or GIF. For an separate video or GIF I need the integrated animation studio in creo - at least this is what I read.

For now - when I switch between normal view and explosion view and back to normal view there is no smooth transition inbetween those views - the description "digital behaviour" would be suitable. So, how can I "slow down" the animation or the transition? I also saw, that my creo is showing "Animation images were skipped" in the lower notification bar. 

 

Maybe you could help me?!

 

Thanks in advance.

 

 

7 REPLIES 7

Look at these config options:

 

animate_explode_states
yes*, no
Yes—The transition between explode states is animated.
 

explode_animation_max_time

Category: Model Display

Description: Sets the maximum amount of time for an animation between explode states.

Values:

Default Values: 1.000000

========================================
Involute Development, LLC
Consulting Engineers
Specialists in Creo Parametric

I looked at those config options:

 

animate_explode_states:

My default was "yes" and there is no difference if I change it to "no" and back to "yes" - each time no difference.

 

explode_animation_max_time:

my default was 1.000 and I first set it on 3.000 - no difference. After this, I set it to 10.000 no difference.

The only difference I recognized was:

when I pressed the explode view button the system seems to calculate in the backround and after app. 3seconds it switched as fast as with the default value.

Same on the 10.000 value but it took even longer - app. 10.000

 

the strange thing is, when I change it from 1 to 3 or from 3 to 10 or from 10 to 3 - every time when I press the explode view button it shows in the description bar "the single image is processed at time 3.000" (or 10.00 when I switch it to 10.00)

 

When I switched the "explode _animation_max_time" the value "animate_explode_states" was set to "yes*" so it should work fine but it didn´t...I don´t know why.

 

You need to provide more details and example data. It is difficult to speculate about what is happening from a verbal description. A video of the steps you are taking when testing this will probably help diagnose things. What version of Creo are you working in?

========================================
Involute Development, LLC
Consulting Engineers
Specialists in Creo Parametric

More info may help - yes.

 

I am working with the PTC Creo Version 6. Attached you can find the screen recorder files which I just made. I made a example assembly for better understanding. the explotion view I introduced as known - no problems there I think.

 

Video default is showing the default status and the default values of "animate_explode_states" and "explode_animation_max_time"

 

Video config is showing the config parameters and the changing of the value "explode_animation_max_time" from 1.000 t0 10.000.

 

Video 10sec. is showing the behaviour after the change of "explode_animation_max_time" from 1.000 to 10.000 with no change.

 

I don´t think that the model is the problem because I get this behaviour with other models too. If you think different please let me know.

The animation sequence duration does appear to be increasing with the change to the config setting for time. It appears that the issue is that only a single frame is used to create the animation. I am not aware of a config option controlling frame display for explode states but there may be one.

 

Try to launch Creo with only the default config settings as a test case (use only the default config.pro from install).

 

This is a test case using the default config settings in Creo 4 with a 1 sec animation duration.

 

========================================
Involute Development, LLC
Consulting Engineers
Specialists in Creo Parametric

Yes - the animation uses only 1 frame or at least very few frames for the animation. The increase of the value "explode_animation_max_time" makes only the difference that the start where the very short "animation" will be shifted for the amount which is set.

 

So - regarding the config.pro I looked it up and saw that the software is provided by an software prvider not PTC directly. I will ask a guy at this company to check this problem...maybe they changed something on the config.pro which causes my problem...

 

I will keep you in touch with updates. Thanks so far for the help!

StephenW
23-Emerald II
(To:Model_1975)

To test with the default settings, rename the config.pro to something else, I usually use something simple like xconfig.pro since I know I will want to rename it back.

Before doing this, it will be helpful to look at where you are loading your config.pro files from (sometimes there are more than one). You can see this using FILE - OPTIONS - CONFIGURATION EDITOR  and push the drop down arrow next to the Show:

In  my example image, I am loading 2 config.pro files and 1 config.sup file.

 

StephenWilliams_1-1620995305272.png

 

 

Announcements
NEW Creo+ Topics: Real-time Collaboration