cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - New to the community? Learn how to post a question and get help from PTC and industry experts! X

Getting error, while using .Net core 3.1 with .Net Sdk 5.8

PR_10128653
6-Contributor

Getting error, while using .Net core 3.1 with .Net Sdk 5.8

Hi @gvyakaranam 

 

Did you find a Solution? how can we edit thingworx-common.dll files?

 

1 ACCEPTED SOLUTION

Accepted Solutions
slangley
23-Emerald II
(To:PR_10128653)

Hi @PR_10128653.

 

The .Net SDK only supports .NET Framework, v.4.5.2 or later.   Please refer to the Help Center for more information.

 

Regards.

 

--Sharon

View solution in original post

11 REPLIES 11

Hello @PR_10128653 ,

 

I have checked internally with our dev tem and it is neither advisable nor recommended to edit these OOTB files. However, the answer is yes you can edit ThingWorx-common.dll files. But if you decide to proceed editing these files, pls keep in mind that it may cause you upgrade and loss of existing projects. 

Also, What is the purpose of editing these file? pls share your issue so that we can work on the real problem. 

 

Have a good day ahead!

 

Regards

Bhawna

Hi @bchaudhary 

 

I am facing some issue on the .Net Edge SDK , The below function is pointing to the Thingworx Dotnet Dll files, Will PTC Resolve those issues , if its not recommended to edit the dll files or is there any workaround solution is there?.

 

Unhandled exception. System.EntryPointNotFoundException: Unable to find an entry point named 'CopyMemory' in DLL 'kernel32.dll'.
at com.thingworx.communications.common.SecurityClaims.CopyMemory(IntPtr destination, IntPtr source, UInt32 length)
at com.thingworx.communications.common.SecurityClaims.twCopyMemory(IntPtr destination, IntPtr source, UInt32 length)
at RFIDReaderTwxEdge.RFIDReaderClient.<>c__DisplayClass3_0.<Main>b__0(IntPtr password, Int32 maxLength) in C:\QMWB\RFIDReaderTwxEdge\RFIDReaderClient.cs:line 83
at com.thingworx.communications.client.TwApiWrapper.twApi_Connect(UInt32 timeout, Int32 retries)
at com.thingworx.communications.client.TwApiWrapper.Connect(UInt32 timeout, Int16 retries)
at com.thingworx.communications.client.BaseClient.connect()
at com.thingworx.communications.client.ConnectedThingClient.connect()
at com.thingworx.communications.client.BaseClient.start()
at com.thingworx.communications.client.ConnectedThingClient.start()
at RFIDReaderTwxEdge.RFIDReaderClient.startClient(Object state) in C:\QMWB\RFIDReaderTwxEdge\RFIDReaderClient.cs:line 29
at System.Threading.QueueUserWorkItemCallbackDefaultContext.Execute()
at System.Threading.ThreadPoolWorkQueue.Dispatch()
at System.Threading.PortableThreadPool.WorkerThread.WorkerThreadStart()
at System.Threading.Thread.StartCallback()

C:\QMWB\RFIDReaderTwxEdge\bin\Debug\net6.0\RFIDReaderTwxEdge.exe (process 7388) exited with code -532462766.

slangley
23-Emerald II
(To:PR_10128653)

Hi @PR_10128653.

 

The .Net SDK only supports .NET Framework, v.4.5.2 or later.   Please refer to the Help Center for more information.

 

Regards.

 

--Sharon

PR_10128653
6-Contributor
(To:slangley)

HI @slangley 

 

The Thingworx .Net SDK is not working in the .Net Framework 6 .

 

My Target .Net Framework version is  6 , is it TWX .Net SDK tested on .Net Framework 6?

slangley
23-Emerald II
(To:slangley)

Hi @PR_10128653.

 

I checked the Microsoft site for .Net Framework downloads and the latest one I found was 4.8.1.  The recommended version is 4.8.

 

Can you confirm the version of your o/s?  Where did you get .Net Framework 6?

 

Regards.

 

--Sharon

PR_10128653
6-Contributor
(To:slangley)

HI @slangley 

 

Thanks for the Reply.  My OS Details are

 

Windows Edition: Windows 10 Enterprise

Version:22H2

 

Latest .Net Long Term Support Version is :.Net 6.0 .16 which was released at April 11,2023

 

.Net Download URL: https://dotnet.microsoft.com/en-us/download

 

 

PR_10128653_0-1686622710256.png

 

Hi @slangley 

 

I mistyped earlier , i was using .net 6.0, will sdk only supports .net framework??

slangley
23-Emerald II
(To:PR_10128653)

Hi @PR_10128653.

 

Have you been able to resolve your issue with .NET Framework?

 

Regards.

 

--Sharon

PR_10128653
6-Contributor
(To:slangley)

hi @slangley 

 

Yes, there is no issues on .NET framework 4.8.1, SDK is working as expected.

 

 

slangley
23-Emerald II
(To:PR_10128653)

Hi @PR_10128653.

 

That's good to hear!

 

Please mark the appropriate response as the Accepted Solution for the benefit of others with the same issue.

 

Regards.

 

--Sharon

slangley
23-Emerald II
(To:slangley)

Hi @PR_10128653.

 

As previously advised, .Net SDK 5.8 only supports .NET Framework, v4.5.2 or later.

 

Please let me know if you have further questions.

 

Regards.

 

--Sharon

Top Tags